<!doctype html>
<html lang="en">
    <head>
        <meta charset="utf-8">
        <title>Asahi Linux for Apple Silicon has come a long way in a few months | AppleInsider</title>
        <meta name="description" content="Asahi, a project to bring Linux to the Apple Silicon Mac, has released a new progress report that details expanded USB and peripheral support.">
        <meta name="keywords" content="Apple, Apple Inc, iPhone, iPad, iPod touch, iPod nano, Apple TV, Apple, iPod shuffle, iphone 6, iphone 6s, ios 9, ios9, iTunes, i mac, mac os x, mac osx, Apple Computer, Apple Computer Inc., Mac OS X, iMac, iBook, Mac Pro, MacBook Pro, Magic Pad, Magic Mouse, iPod classic, App Store, iTunes Store, iBook Store, mac book, Microsoft, Adobe, Research in Motion, RIM, Nokia, Samsung, Google, Nvidia, Intel">
        <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, shrink-to-fit=no">
        <meta name="google-site-verification" content="p84Cqvyr9UB11ipMY8Bmt_X7K69Ay95_1EQ_BwRgU1c">
        <meta name="robots" content="index,follow">
        <meta property="fb:pages" content="135590163123753">
        <meta name="apple-mobile-web-app-title" content="AppleInsider">

        <meta name="theme-color" content="#171e27" media="(prefers-color-scheme: light)">
        <meta name="theme-color" content="#303538" media="(prefers-color-scheme: dark)">

		<link rel="apple-touch-icon" sizes="57x57" href="https://photos5.appleinsider.com/v9/images/apple-touch-icon-57.png">
		<link rel="apple-touch-icon" sizes="72x72" href="https://photos5.appleinsider.com/v9/images/apple-touch-icon-72.png">
		<link rel="apple-touch-icon" sizes="114x114" href="https://photos5.appleinsider.com/v9/images/apple-touch-icon-114.png">
		<link rel="apple-touch-icon" sizes="144x144" href="https://photos5.appleinsider.com/v9/images/apple-touch-icon-144.png">
		<link rel="apple-touch-icon" href="https://photos5.appleinsider.com/v9/images/apple-touch-icon-144.png">
        
          <link rel="amphtml" href="https://appleinsider.com/articles/22/11/22/asahi-linux-for-apple-silicon-has-come-a-long-way-in-a-few-months/amp/" />
  <meta property="og:url" content="https://appleinsider.com/articles/22/11/22/asahi-linux-for-apple-silicon-has-come-a-long-way-in-a-few-months"/>
  <meta property="og:image" content="https://photos5.appleinsider.com/gallery/51512-101980-asahi-linux-for-mac-xl.jpg"/>
  <meta property="og:title" content="Asahi Linux for Apple Silicon has come a long way in a few months | AppleInsider"/>
  <meta property="og:description" content="Asahi, a project to bring Linux to the Apple Silicon Mac, has released a new progress report that details expanded USB and peripheral support."/>
  <meta property="fb:app_id" content="908219582587578" />
  <meta property="og:type" content="website" /> 
  <meta property="og:locale" content="en_US" /> 
  <meta property="og:site_name" content="AppleInsider" /> 
  <meta name="twitter:card" content="summary_large_image" /> 
  <meta name="twitter:site" content="@appleinsider" /> 
  <meta name="twitter:creator" content="@appleinsider" /> 
  <meta name="twitter:domain" content="appleinsider.com" /> 
  <meta name="twitter:title" content="Asahi Linux for Apple Silicon has come a long way in a few months | AppleInsider" /> 
  <meta name="twitter:description" content="Asahi, a project to bring Linux to the Apple Silicon Mac, has released a new progress report that details expanded USB and peripheral support." /> 
  <meta name="twitter:image" content="https://photos5.appleinsider.com/gallery/51512-101980-asahi-linux-for-mac-xl.jpg" /> 
  <meta name="twitter:url" content="https://appleinsider.com/articles/22/11/22/asahi-linux-for-apple-silicon-has-come-a-long-way-in-a-few-months" /> 

        <!-- Speed up some global things -->        
        <link rel="preconnect" href="https://photos5.appleinsider.com" crossorigin>
        <link rel="preconnect" href="https://www.google-analytics.com">
        <link rel="preconnect" href="https://secure.quantserve.com">
        <link rel="preconnect" href="https://biddr.brealtime.com">
        <link rel="preconnect" href="https://securepubads.g.doubleclick.net">

        <link rel="preload" href="https://photos5.appleinsider.com/v10/fonts/Inter/Inter-Regular.woff2?v=3.19" as="font" type="font/woff2" crossorigin>
        <link rel="preload" href="https://photos5.appleinsider.com/v10/fonts/Inter/Inter-Black.woff2?v=3.19" as="font" type="font/woff2" crossorigin>
        <link rel="preload" href="https://photos5.appleinsider.com/v10/fonts/Inter/Inter-Bold.woff2?v=3.19" as="font" type="font/woff2" crossorigin>
        <link rel="preload" href="https://photos5.appleinsider.com/v10/fonts/Inter/Inter-ExtraBold.woff2?v=3.19" as="font" type="font/woff2" crossorigin>
        <link rel="preload" href="https://photos5.appleinsider.com/v10/fonts/Inter/Inter-Italic.woff2?v=3.19" as="font" type="font/woff2" crossorigin>
        <link rel="preload" href="https://photos5.appleinsider.com/v10/fonts/Inter/Inter-ExtraLightItalic.woff2?v=3.19" as="font" type="font/woff2" crossorigin>
        <link rel="preload" href="https://photos5.appleinsider.com/v10/fonts/Inter/Inter-Medium.woff2?v=3.19" as="font" type="font/woff2" crossorigin>
        <link rel="preload" href="https://securepubads.g.doubleclick.net/tag/js/gpt.js" as="script">

        <link rel="alternate" type="application/rss+xml" href="/appleinsider.rss" title="AppleInsider News">
        <link rel="canonical" href="https://appleinsider.com/articles/22/11/22/asahi-linux-for-apple-silicon-has-come-a-long-way-in-a-few-months" />

        <script>
        const Appleinsider = {
            'siteUrl': 'https://appleinsider.com',
            'forumsUrl': 'https://forums.appleinsider.com', 
            'dealsUrl': 'https://appleinsider.com/deals',
            'pgUrl': 'https://prices.appleinsider.com',
            'subSection': 'article',
            'subSectionTarget': 'default',
            'cb' : Math.round(new Date().getTime() / 1000)
        };
        window.googletag = window.googletag || {cmd: []};
        </script>

        <!-- GDPR -->        
        <script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://rabbitrifle.com/v2jnvgSKkpXownmiyOeY4vBQ_ipS-uZoxWCYYpWLkwFkI7kPFbTR7Nw5iv1Z2Ju-N",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){function t(){(t.q=t.q||[]).push(arguments)}t.v=1,o[n]=o[n]||t})(window,String.fromCharCode(97,100,109,105,114,97,108));!(function(o,t,n,c){function e(n){(function(){try{return(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]>0}catch(o){}return!1})()&&(n=o[t].pubads())&&n.setTargeting("admiral-engaged","true")}(c=o[t]=o[t]||{}).cmd=c.cmd||[],typeof c.pubads===n?e():typeof c.cmd.unshift===n?c.cmd.unshift(e):c.cmd.push(e)})(window,"googletag","function");;;!(function(t,n,i,e,o){function a(){for(var t=[],i=0;i<arguments.length;i++)t.push(arguments[i]);if(!t.length)return o;"ping"===t[0]?t[2]({gdprAppliesGlobally:!!n.__cmpGdprAppliesGlobally,cmpLoaded:!1,cmpStatus:"stub"}):t.length>0&&o.push(t)}function c(t){if(t&&t.data&&t.source){var e,o=t.source,a="string"==typeof t.data&&t.data.indexOf("__tcfapiCall")>=0;(e=a?((function(t){try{return JSON.parse(t)}catch(n){}})(t.data)||{}).__tcfapiCall:(t.data||{}).__tcfapiCall)&&n[i](e.command,e.version,(function(t,n){var i={__tcfapiReturn:{returnValue:t,success:n,callId:e.callId}};o&&o.postMessage(a?JSON.stringify(i):i,"*")}),e.parameter)}}!(function f(){if(!window.frames[e]){var n=t.body;if(n){var i=t.createElement("iframe");i.style.display="none",i.name=e,n.appendChild(i)}else setTimeout(f,5)}})(),o=[],a.v=1,"function"!=typeof n[i]&&(n[i]=n[i]||a,n.addEventListener?n.addEventListener("message",c,!1):n.attachEvent&&n.attachEvent("onmessage",c))})(document,window,"__tcfapi","__tcfapiLocator");;!(function(n,t,i,u,e,o,r){function a(n){if(n){var u=(n.data||{}).__uspapiCall;u&&t[i](u.command,u.version,(function(t,i){n.source.postMessage({__uspapiReturn:{returnValue:t,success:i,callId:u.callId}},"*")}))}}!(function f(){if(!window.frames[u]){var t=n.body;if(t){var i=n.createElement("iframe");i.style.display="none",i.name=u,t.appendChild(i)}else setTimeout(f,5)}})();var s={getUSPData:function(n,t){return n!==1?t&&t(null,!1):t&&t({version:null,uspString:null},!1)}};function c(n,t,i){return s[n](t,i)}c.v=1,"function"!=typeof t[i]&&(t[i]=t[i]||c,t.addEventListener?t.addEventListener("message",a,!1):t.attachEvent&&t.attachEvent("onmessage",a)),o=n.createElement(e),r=n.getElementsByTagName(e)[0],o.src="https://fearlessfaucet.com/v2qdvAZxtP523qaRY4KCxOSYwAmXaY_1rIrFP_HNjBl3uh7zPUjvGqzId5qeiFwl5vGhYTiPMQhnymXMYEQ",r.parentNode.insertBefore(o,r)})(document,window,"__uspapi","__uspapiLocator","script");</script>

        <!-- Start Ads -->
        <script src="https://biddr.brealtime.com/77432379-1625.js"></script>
        <script>
            !function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
            apstag.init({
                pubID: '434bb5e4-3704-4b75-b36c-785a444462bd',
                adServer: 'googletag',
                simplerGPT: true,
                schain: {
                    complete: 1,
                    ver: '1.0',
                    nodes: [
                        {
                            asi: 'theadengine.com',
                            sid: '01286',
                            hp: 1,
                        },
                    ],
                },
            });
        </script>
        <script src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
        <script src="https://photos5.appleinsider.com/v10/js/ady.js?id=ef56656a96a330577804"></script>
        <!-- End Ads -->

        <!-- GA4 Transistion alongside old UA test -->
        <script async src="https://www.googletagmanager.com/gtag/js?id=G-YEFM13KEVL"></script>
        <script>
            window.dataLayer = window.dataLayer || [];
            function gtag(){dataLayer.push(arguments);}
            gtag('js', new Date());
            
            /* Color scheme detection */
            let isDark = window.matchMedia && window.matchMedia('(prefers-color-scheme: dark)').matches;
            isDark = (isDark) ? 'dark' : 'light';
            //gtag('set', 'prefers_color_scheme', isDark );

            gtag('config', 'G-YEFM13KEVL', { 'prefers_color_scheme': isDark });
        </script>

        <link rel="stylesheet" href="https://photos5.appleinsider.com/v10/css/vendor.css?id=014078d62aeaa1ced5b0" media="all">
        <link rel="stylesheet" href="https://photos5.appleinsider.com/v10/css/app.css?id=9b452d94680445275a05" media="all">
        
        <script src="https://code.jquery.com/jquery-3.6.1.min.js" integrity="sha256-o88AwQnZB+VDvE9tvIXrMQaPlFFSUTR+nldQm1LuPXQ=" crossorigin="anonymous"></script>
        <!-- Page Header Scripts -->
         
  <script>Appleinsider.subSection = 'article';</script>
  <link rel="stylesheet" href="https://photos5.appleinsider.com/v9/css/pg_vendors.css?1.4" media="all">
  <link rel="stylesheet" href="https://photos5.appleinsider.com/v9/css/font-awesome/css/font-awesome.min.css?1.11d" media="all">
        <!-- End Page Header Scripts -->

              <script type="application/ld+json">
{
      "@context": "https://schema.org",
      "@type": "NewsArticle",
      "mainEntityOfPage":{
        "@type": "WebPage",
        "@id": "https://appleinsider.com/articles/22/11/22/asahi-linux-for-apple-silicon-has-come-a-long-way-in-a-few-months"
      },
      "isAccessibleForFree": true,
      "inLanguage": "en-US",
      "headline": "Asahi Linux for Apple Silicon has come a long way in a few months",
      "description": "Asahi, a project to bring Linux to the Apple Silicon Mac, has released a new progress report that details expanded USB and peripheral support.",
      "articleBody": "Asahi, a project to bring Linux to the Apple Silicon Mac, has released a new progress report that details expanded USB and peripheral support.      Asahi Linux    A project to port Linux to Apple Silicon Macs, the latest update to Asahi Linux has new hardware support, new features, and fixes for &quot;longstanding pain points.&quot; It also features a new bleeding-edge kernel branch with support for suspend and the display controller.    The team reminds users to keep their Linux installations up to date. Early in the macOS Ventura betas, they found an issue that would make Linux unbootable after the upgrade.    A package update fixed the bug earlier in 2022. However, they still see users recently upgrading to macOS Ventura, or even the latest 12.x macOS releases, and end up with unbootable Linux installations.    Changes in Asahi    The blog post is a lengthy one, with many new updates. Most of the updates pertain to peripherals, USB-C, and headphones.    Until now, Asahi Linux has only supported USB 2.0 on the Thunderbolt ports. The team now believes that USB 3 support should be reasonably solid, but users should expect some glitches, particularly while quickly hotplugging devices. According to a headline in the post called &quot;USB3, Chapter 2x7 Gen3.1415.&quot; this may include support for USB 3.1.    However, users should be able to fix the glitches by disconnecting and reconnecting the device.    Meanwhile, work continues supporting a Mac&#039;s speakers. The team needs to implement a safety model, so users don&#039;t blow out their speakers, as happened during testing. The speakers remain disabled, but progress is being made.    But thanks to a reverse-engineering of a headphone codec used in newer Macs, Asahi now has headphone jack support.    Support for keyboard backlighting is also included in the new update. However, the team is still working to support display brightness.    It&#039;s a nice update to Asahi Linux, and users should be able to install it and get practical use out of it soon. Advanced Mac users can find installation instructions on the Asahi Linux.",
      "image": "https://photos5.appleinsider.com/gallery/51512-101980-asahi-linux-for-mac-xl.jpg",
      "datePublished": "2022-11-22T16:55:14+00:00",
      "dateModified": "2022-11-22T16:55:14+00:00",
      "author": {
        "@type": "Person",
        "name": "Andrew Orr"
      },
      "publisher": {
        "@type": "Organization",
        "name": "AppleInsider",
        "sameAs": ["https://www.facebook.com/AppleInsiderdotcom", "https://www.instagram.com/appleinsider", "https://www.youtube.com/appleinsider", "https://twitter.com/appleinsider"],
        "logo": {
          "@type": "Imageobject",
          "url": "https://photos5.appleinsider.com/mobile/img/wordmark-large.png",
          "width": 420,
          "height": 72
        }
      }
    }
</script>
  
      </head>

    <body>
        <!--[if lte IE 8]>
        <p class="browsehappy">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> to improve your experience.</p>
        <![endif]-->
        <header class="header header-desktop hidden-xs">
    <nav class="navbar navbar-default hidden-xs" id="desktop-nav" aria-label="Primary">
        <div class="container">
            <div class="col-sm-1 header-bookend">
                <a href="https://appleinsider.com"><img loading="lazy" src="https://photos5.appleinsider.com/v10/images/logo-2x.png" alt="AppleInsider logo" width="28" height="28" ara-label="Return Home"></a>
            </div>

            <div class="col-sm-10 text-center">
                <ul class="nav navbar-nav">
                    <li class="inl"><a href="https://appleinsider.com" title="News">News</a></li>
                    <li class="inl"><a href="https://appleinsider.com/reviews" title="Reviews">Reviews</a></li>
                    <li class="inl"><a href="https://appleinsider.com/how-to" title="How-Tos">How-Tos</a></li>
                    <li class="inl"><a href="https://appleinsider.com/videos" title="Videos">Videos</a></li>
                    <li class="inl dropdown dt-dd">
                        <button class="dropdown-toggle" type="button" data-toggle="dropdown">
                            <span class="uc">Deals</span> <span class="caret"></span>
                        </button>
                        <ul class="dropdown-menu dt-dd">
                            <li><a href="https://appleinsider.com/deals" title="Apple Deals">Apple Deals</a></li>
                            <li><a href="https://appleinsider.com/deals/best-macbook-air-deals" title="MacBook Air Deals">MacBook Air Deals</a></li>
                            <li><a href="https://appleinsider.com/deals/best-macbook-pro-deals" title="MacBook Pro Deals">MacBook Pro Deals</a></li>
                            <li><a href="https://appleinsider.com/deals/best-mac-mini-deals" title="Mac mini Deals">Mac mini Deals</a></li>
                            <li><a href="https://appleinsider.com/deals/best-mac-studio-deals" title="Mac Studio Deals">Mac Studio Deals</a></li>
                            <li><a href="https://appleinsider.com/deals/best-ipad-deals" title="iPad Deals">iPad Deals</a></li>
                            <li><a href="https://appleinsider.com/deals/best-apple-airpods-deals" title="AirPods Deals">AirPods Deals</a></li>
                            <li><a href="https://appleinsider.com/deals/best-apple-watch-deals" title="Apple Watch Deals">Apple Watch Deals</a></li>
                            <li><a href="https://appleinsider.com/deals/best-imac-deals" title="iMac Deals">iMac Deals</a></li>
                            <li><a href="https://appleinsider.com/deals/best-iphone-deals" title="iPhone Deals">iPhone Deals</a></li>
                            <li><a href="https://appleinsider.com/deals/apple-trade-in-deals" title="Apple Trade In Deals">Apple Trade-in Deals</a></li>
                            <li><a href="https://appleinsider.com/deals/apple-authorized-resellers" title="Apple Authorized Resellers">Apple Authorized Resellers</a></li>
                            <li><a href="https://appleinsider.com/deals/apple-student-discount" title="Apple Student Discount">Apple Student Discount</a></li>                            
                            <li><a href="https://appleinsider.com/deals/best-mac-for-students" title="Macs for Students">Macs for Students</a></li>
                        </ul>
                    </li>

                    <li class="inl dropdown dt-dd">
                        <button class="dropdown-toggle" type="button" data-toggle="dropdown">
                            <span class="uc">Price Guides</span> <span class="caret"></span>
                        </button>
                        <ul class="dropdown-menu dt-dd">
                            <li><a href="https://prices.appleinsider.com" title="Apple Prices">Apple Prices</a></li>
                            <li><a href="https://prices.appleinsider.com/current-gen" title="iMac, Mac mini, MacBook Price Guide">MacBook, iMac &amp; Mac mini Prices</a></li>
                            <li><a href="https://prices.appleinsider.com/ipad" title="iPad Price Guide">iPad Prices</a></li>
                            <li><a href="https://prices.appleinsider.com/apple-watch" title="Apple Watch Price Guide">Apple Watch Prices</a></li>
                            <li><a href="https://prices.appleinsider.com/iphone" title="iPhone Price Guide">iPhone Prices</a></li>
                            <li><a href="https://prices.appleinsider.com/wireless" title="AirTag, Apple TV Price Guide">Apple TV &amp; AirTag Prices</a></li>
                            <li><a href="https://prices.appleinsider.com/music" title="Beats, HomePod, AirPods Price Guide">AirPods, HomePod &amp; Beats Prices</a></li>
                            <li><a href="https://prices.appleinsider.com/trade-in" title="iPad, iPhone Trade In Price Guide">iPad &amp; iPhone Trade-in Values</a></li>
                        </ul>
                    </li>

                    <li class="inl dropdown dt-dd">
                        <button class="dropdown-toggle" type="button" data-toggle="dropdown" aria-label="Apple A Through Z">
                            <span class="uc">Apple A-Z</span> <span class="caret"></span>
                        </button>
                        <ul class="dropdown-menu dt-dd">
                            <li><a href="https://appleinsider.com/inside/airpods" title="AirPods">AirPods</a></li>
<li><a href="https://appleinsider.com/inside/apple-tv" title="Apple TV">Apple TV</a></li>
<li><a href="https://appleinsider.com/inside/apple-watch" title="Apple Watch">Apple Watch</a></li>
<li><a href="https://appleinsider.com/inside/homepod" title="HomePod">HomePod</a></li>

<li><a href="https://appleinsider.com/inside/iPad" title="iPad">iPad</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/ipad-mini" title="iPad mini">iPad mini</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/ipad-pro" title="iPad mini">iPad Pro</a></li>

<li><a href="https://appleinsider.com/inside/iphone" title="iPhone">iPhone</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/iphone-12" title="iPhone 12">iPhone 12</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/iphone-13" title="iPhone 13">iPhone 13</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/iphone-13-pro" title="iPhone 13 Pro">iPhone 13 Pro</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/iphone-14" title="iPhone 14">iPhone 14</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/iphone-14-pro" title="iPhone 14 Pro">iPhone 14 Pro</a></li>

<li><a href="https://appleinsider.com/inside/mac" title="Mac">Mac</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/macbook-pro" title="MacBook Pro">MacBook Pro</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/macbook-air" title="MacBook Air">MacBook Air</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/mac-studio" title="Mac Studio">Mac Studio</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/imac" title="iMac">iMac</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/mac-mini" title="Mac mini">Mac mini</a></li>

<li><a href="https://appleinsider.com/inside" title="More Apple A-Z">More...</a>
                        </ul>
                    </li>

                    <li class="inl dropdown dt-dd">
                        <button class="dropdown-toggle" type="button" data-toggle="dropdown">
                            <span class="uc">More</span> <span class="caret"></span>
                        </button>
                        <ul class="dropdown-menu dt-dd">
                            <li><a href="https://forums.appleinsider.com" title="Forums">Forums</a></li>
                            <li><a href="https://appleinsider.com/podcast" title="Podcasts">Podcasts</a></li>
                            <li><a href="https://appleinsider.com/contact" title="Contact Us">Contact Us</a></li>
                            <li><a href="https://appleinsider.com/advertising" title="Advertise on Appleinsider">Advertise</a></li>
                        </ul>
                    </li>
                    <li class="inl hidden-xs hidden-sm hidden-md stock-ticker" aria-label="Stock Price">
                        AAPL: 150.89 ( <span class="Stockup">+0.71</span> )                    </li>
                </ul>
            </div>

            <div class="col-sm-1 header-bookend" style="height:58px;">
                <div class="btn-group">
                    <button type="button" class="btn btn-default dropdown-toggle search-btn" data-toggle="dropdown" aria-label="Search" aria-haspopup="true" aria-expanded="false">
                        <span class="glyphicon glyphicon-search mobile-search-glyph" aria-hidden="true"></span>
                    </button>
                    <div class="dropdown-menu dropdown-right-custom">
                        <div class="container">
                            <form class="navbar-form navbar-left search-mobile" role="search" action="/search/">
                                <div class="form-group">
                                    <div class="box">
                                        <span class="glyphicon glyphicon-search mobile-search-glyph" aria-hidden="true"></span>
                                    </div>
                                    <div class="box search-input">
                                        <input type="text" class="form-control" id="search-in-dt" name="query" placeholder="Search AppleInsider" title="Search">
                                    </div>
                                    <span class="box glyphicon glyphicon-remove mobile-remove-glyph" aria-hidden="true"></span>
                                </div>
                            </form>
                        </div>
                    </div>
                </div>
            </div>
        </div>
    </nav>
</header>
<div class="push">&nbsp;</div>
<!-- End Desktop Nav -->


<!-- Begin Mobile Nav -->
<nav class="navbar navbar-default navbar-fixed-top visible-xs" style="max-width:100%" aria-label="Primary">
    <div class="container" style="max-width:100%;">
        <div class="row navbar-header">
            <div class="col-xs-3">
                <button id="nav-toggle" type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#js-navbar-collapse">
                    <span class="collapsed-nav"> <span class="sr-only">Toggle navigation</span> <span class="icon-bar"></span> <span class="icon-bar"></span> </span> <span class="open-nav"> <img loading="lazy" src="https://photos5.appleinsider.com/v10/images/navClose.png" alt="Close Nav"></span>
                </button>
            </div>
            <div class="col-xs-6 hidden-md hidden-lg hidden-sm">
                <a class="center-block text-center" href="https://appleinsider.com"><img loading="lazy" class="mobile-logo" src="https://photos5.appleinsider.com/v10/images/Logo_mobile.png" alt="AppleInsider Logo"></a>
            </div>
            <div class="col-xs-3 text-right">
                <div class="btn-group search-bar-mobile">
                    <button type="button" class="btn btn-default dropdown-toggle search-btn" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" title="Search">
                        <span class="glyphicon glyphicon-search mobile-search-glyph" aria-hidden="true"></span>
                    </button>
                    <div class="dropdown-menu dropdown-right-custom">
                        <div class="container">
                            <div class="row">
                                <div class="col-xs-12">
                                    <form class="navbar-form navbar-left search-mobile" tabindex="1" role="search" action="/search/">
                                        <div class="form-group">
                                            <div class="boxes">
                                                <div class="box"> <span class="glyphicon glyphicon-search mobile-search-glyph" aria-hidden="true"></span></div>
                                                <div class="box search-input"> <input type="text" id="search-in-mob" class="form-control" name="query" placeholder="Search AppleInsider" title="Search"></div>
                                                <div class="box closeSearch"> <span class="glyphicon glyphicon-remove mobile-remove-glyph" aria-hidden="true"></span></div>
                                            </div>
                                        </div>
                                    </form>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div>

            <div class="collapse navbar-collapse" id="js-navbar-collapse" style="width:100%;">
                <div class="container">
                    <div class="row">
                        <ul class="nav navbar-nav mobile-sett">
                            <li style="border-bottom:1px solid var(--primary-nav-hr);"><a href="https://appleinsider.com" title="News">News</a></li>
                            <li class="inl"><a href="https://appleinsider.com/how-to" title="How-Tos">How-Tos</a></li>
                            <li class="dropdown">
                                <a href="#" class="dropdown-toggle mobile-topics-subnav subnav-adjust" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false" aria-label="Apple A Through Z">
                                    <div class="col-xs-11 subnav-adjust">Apple A-Z</div>
                                    <div class="col-xs-1 subnav-adjust"><span class="glyphicon glyphicon-chevron-down" aria-hidden="true"></span></div>
                                </a>
                                <ul class="dropdown-menu mobile-sett mobile-subnav">
                                    <li><a href="https://appleinsider.com/inside/airpods" title="AirPods">AirPods</a></li>
<li><a href="https://appleinsider.com/inside/apple-tv" title="Apple TV">Apple TV</a></li>
<li><a href="https://appleinsider.com/inside/apple-watch" title="Apple Watch">Apple Watch</a></li>
<li><a href="https://appleinsider.com/inside/homepod" title="HomePod">HomePod</a></li>

<li><a href="https://appleinsider.com/inside/iPad" title="iPad">iPad</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/ipad-mini" title="iPad mini">iPad mini</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/ipad-pro" title="iPad mini">iPad Pro</a></li>

<li><a href="https://appleinsider.com/inside/iphone" title="iPhone">iPhone</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/iphone-12" title="iPhone 12">iPhone 12</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/iphone-13" title="iPhone 13">iPhone 13</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/iphone-13-pro" title="iPhone 13 Pro">iPhone 13 Pro</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/iphone-14" title="iPhone 14">iPhone 14</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/iphone-14-pro" title="iPhone 14 Pro">iPhone 14 Pro</a></li>

<li><a href="https://appleinsider.com/inside/mac" title="Mac">Mac</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/macbook-pro" title="MacBook Pro">MacBook Pro</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/macbook-air" title="MacBook Air">MacBook Air</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/mac-studio" title="Mac Studio">Mac Studio</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/imac" title="iMac">iMac</a></li>
<li class="nav-indent"><a href="https://appleinsider.com/inside/mac-mini" title="Mac mini">Mac mini</a></li>

<li><a href="https://appleinsider.com/inside" title="More Apple A-Z">More...</a>
                                </ul>
                            </li>
                            <li><a href="https://appleinsider.com/reviews" title="Reviews">Reviews</a></li>
                            <li><a href="https://appleinsider.com/videos" title="Videos">Videos</a></li>
                            <li class="dropdown">
                                <a href="#" class="dropdown-toggle mobile-topics-subnav subnav-adjust" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">
                                    <div class="col-xs-11 subnav-adjust">Deals</div>
                                    <div class="col-xs-1 subnav-adjust"><span class="glyphicon glyphicon-chevron-down" aria-hidden="true"></span></div>
                                </a>
                                <ul class="dropdown-menu mobile-sett mobile-subnav">
                                    <li><a href="https://appleinsider.com/deals" title="Apple Deals">Apple Deals</a></li>
                                    <li><a href="https://appleinsider.com/deals/best-macbook-air-deals" title="MacBook Air Deals">MacBook Air Deals</a></li>
                                    <li><a href="https://appleinsider.com/deals/best-macbook-pro-deals" title="MacBook Pro Deals">MacBook Pro Deals</a></li>
                                    <li><a href="https://appleinsider.com/deals/best-mac-mini-deals" title="Mac mini Deals">Mac mini Deals</a></li>
                                    <li><a href="https://appleinsider.com/deals/best-mac-studio-deals" title="Mac Studio Deals">Mac Studio Deals</a></li>
                                    <li><a href="https://appleinsider.com/deals/best-ipad-deals" title="iPad Deals">iPad Deals</a></li>
                                    <li><a href="https://appleinsider.com/deals/best-apple-airpods-deals" title="AirPods Deals">AirPods Deals</a></li>
                                    <li><a href="https://appleinsider.com/deals/best-apple-watch-deals" title="Apple Watch Deals">Apple Watch Deals</a></li>
                                    <li><a href="https://appleinsider.com/deals/best-imac-deals" title="iMac Deals">iMac Deals</a></li>
                                    <li><a href="https://appleinsider.com/deals/best-iphone-deals" title="iPhone Deals">iPhone Deals</a></li>
                                    <li><a href="https://appleinsider.com/deals/apple-trade-in-deals" title="Apple Trade In Deals">Apple Trade-in Deals</a></li>
                                    <li><a href="https://appleinsider.com/deals/apple-authorized-resellers" title="Apple Authorized Resellers">Apple Authorized Resellers</a></li>
                                    <li><a href="https://appleinsider.com/deals/apple-student-discount" title="Apple Student Discount">Apple Student Discount</a></li>                            
                                    <li><a href="https://appleinsider.com/deals/best-mac-for-students" title="Macs for Students">Macs for Students</a></li>
                                </ul>
                            </li>

                            <li class="dropdown">
                                <a href="#" class="dropdown-toggle mobile-topics-subnav subnav-adjust" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">
                                    <div class="col-xs-11 subnav-adjust">Price Guides</div>
                                    <div class="col-xs-1 subnav-adjust"><span class="glyphicon glyphicon-chevron-down" aria-hidden="true"></span></div>
                                </a>
                                <ul class="dropdown-menu mobile-sett mobile-subnav">
                                    <li><a href="https://prices.appleinsider.com" title="Apple Prices">Apple Prices</a></li>
                                    <li><a href="https://prices.appleinsider.com/current-gen" title="iMac, Mac mini, MacBook Price Guide">MacBook, iMac &amp; Mac mini Prices</a></li>
                                    <li><a href="https://prices.appleinsider.com/ipad" title="iPad Price Guide">iPad Prices</a></li>
                                    <li><a href="https://prices.appleinsider.com/apple-watch" title="Apple Watch Price Guide">Apple Watch Prices</a></li>
                                    <li><a href="https://prices.appleinsider.com/iphone" title="iPhone Price Guide">iPhone Prices</a></li>
                                    <li><a href="https://prices.appleinsider.com/wireless" title="AirTag, Apple TV Price Guide">Apple TV &amp; AirTag Prices</a></li>
                                    <li><a href="https://prices.appleinsider.com/music" title="Beats, HomePod, AirPods Price Guide">AirPods, HomePod &amp; Beats Prices</a></li>
                                    <li><a href="https://prices.appleinsider.com/trade-in" title="iPad, iPhone Trade In Price Guide">iPad &amp; iPhone Trade-in Values</a></li>
                                </ul>
                            </li>
                            <li><a href="https://appleinsider.com/podcast" title="Podcasts">Podcasts</a></li>
                            <li><a href="https://forums.appleinsider.com" title="Forums">Forums</a></li>
                            <li><a href="https://appleinsider.com/submit_story" title="Contact Us">Contact Us</a></li>
                            <li><a href="https://appleinsider.com/advertising" title="Advertise on Appleinsider">Advertise on AI</a></li>
                        </ul>
                    </div>


                    <div class="row" style="margin: 15px auto;">
                        <div class="col-xs-2">
                            <a href="https://www.facebook.com/AppleInsiderdotcom" title="AppleInsider on Facebook">
                            <div class="footer-social-image-FB" aria-hidden="true"></div>
                            </a>
                        </div>
                        <div class="col-xs-2">
                            <a href="https://twitter.com/appleinsider" title="AppleInsider on Twitter">
                            <div class="footer-social-image-T" aria-hidden="true"></div>
                            </a>
                        </div>
                        <div class="col-xs-2">
                            <a href="https://www.instagram.com/appleinsider" title="AppleInsider on Instragram">
                            <div class="footer-social-image-E" aria-hidden="true"></div>
                            </a>
                        </div>
                        <div class="col-xs-2">
                            <a href="https://discord.gg/F4UFPVMhgM" title="Join the AppleInsider Discord Server">
                            <div class="footer-social-discord" aria-hidden="true"></div>
                            </a>
                        </div>
                        <div class="col-xs-2">
                            <a href="https://www.linkedin.com/company/appleinsider" title="AppleInsider on LinkedIn">
                            <div class="footer-social-linkedin" aria-hidden="true"></div>
                            </a>
                        </div>
                        <div class="col-xs-2">
                            <a href="https://www.youtube.com/appleinsider" title="Watch AppleInsider on YouTube">
                                <div class="footer-social-youtube" aria-hidden="true"></div>
                            </a>
                        </div>
                    </div>

                    <div class="row">
                        <div class="col-xs-12" style="text-align: center; padding-bottom: 15px;">
                            AAPL: 150.89 ( <span class="Stockup">+0.71</span> )                        </div>
                    </div>

                    <div class="row">
                        <div class="col-xs-12 mobile-footer"> 
                            <p>Copyright &copy; 2022, Quiller Media, Inc.</p>
                            <p> <a href="https://appleinsider.com/contact" title="Contact Us">Contact Us</a> | <a href="https://appleinsider.com/privacy" title="Privacy policy">Privacy Policy</a></p>
                        </div>
                    </div>
                </div>
            </div>

        </div>
    </div>    
</nav>
<!-- End Mobile Nav -->

<!-- Super leaderboard Ad -->
<div class="container" style="min-height:50px !important;">
    <div id="div-gpt-ad-1588083483022-0" class="ad-leaderboard desktop hidden-xs hidden-sm hidden-md">
    </div>

    <!-- Tablet only leaderboard -->
    <div id="div-gpt-ad-1594069462585-0" class="ad-leaderboard tablet visible-sm visible-md">
        <!-- Tablet leaderboard Ad -->
    </div>

    <!-- Mobile only leaderboard -->
    <div id="mobile-ad-wrap" class="visible-xs">
        <div id="div-gpt-ad-1612108401781-0" class="ad-leaderboard mobile visible-xs">
        </div>
    </div>
</div>

<div class="container" id="top-half-snap">
    <div class="row main-page">
        <main>
        
 <!-- left side upper half -->
 <div class="col-lg-9">
 <article class="reviews">
      <div class="row">
        <header>
          <div class="col-sm-12">
             
              <!-- <h3 class="hidden-xs hidden-sm">&nbsp;</h3> -->
                      </div>
                    <div class="col-sm-12">
            <h1 class="h1-adjust">Asahi Linux for Apple Silicon has come a long way in a few months</h1>
          </div>
          <div class="row article-hero-social">
  <div class="col-sm-12">
    <div class="avatar-link no-gutters">
      <a href="https://appleinsider.com/editor/Andrew+Orr" title="Andrew Orr">
        <img loading="lazy" class="avatarLG-article img-circle no-left-gutters" src="https://photos5.appleinsider.com/gallery/andrew+orr.jpg" alt="Andrew Orr's Avatar" aria-hidden="true">Andrew Orr</a>
        | <time datetime="2022-11-22T16:55:14+00:00" title="Nov 22, 2022 04:55PM GMT+0000">Nov 22, 2022</time>
    </div>
  </div>
</div>
        </header>
        <div class="row">
          <div class="col-sm-12" id="article-hero" aria-labelledby="hero-cap" role="figure">
                          <p id="hero-cap" class="hero-caption" title="Asahi Linux">Asahi Linux</p>
              <style>
                #article-hero img{margin-top:-1.5em;}
                @media  screen and (min-width:768px){#article-hero img{margin-top:-1.8em;}}
              </style>
                        <a href="https://photos5.appleinsider.com/gallery/51512-101980-asahi-linux-for-mac-xl.jpg">
              <img src="https://photos5.appleinsider.com/gallery/51512-101980-asahi-linux-for-mac-xl.jpg" alt="">
            </a>
          </div>

          <div class="col-sm-12" id="article-social">
          <div class="social-share col-xs-2">&nbsp;</div>
                        <div class="social-share comments col-xs-2">
              <a href="https://forums.appleinsider.com/discussion/229725" title="Read Comments">
                <span class="glyphicon glyphicon-comment" aria-hidden="true">&nbsp;</span>
                <span class="hidden-xs">1 Comments</span>
              </a>
            </div>
                        <div class="social-share facebook col-xs-2">
              <a href="https://www.facebook.com/sharer/sharer.php?u=https://appleinsider.com/articles/22/11/22/asahi-linux-for-apple-silicon-has-come-a-long-way-in-a-few-months" title="Share to Facebook" rel="nofollow">
              <img loading="lazy" src="https://photos5.appleinsider.com/v10/images/facebook.png" alt="Facebook" aria-hidden="true"/><span class="hidden-xs">Facebook</span>
              </a>
            </div>
            <div class="social-share twitter col-xs-2">
              <a href="https://twitter.com/intent/tweet?original_referer=https://appleinsider.com/articles/22/11/22/asahi-linux-for-apple-silicon-has-come-a-long-way-in-a-few-months&text=Asahi+Linux+for+Apple+Silicon+has+come+a+long+way+in+a+few+months&url=https://appleinsider.com/articles/22/11/22/asahi-linux-for-apple-silicon-has-come-a-long-way-in-a-few-months" rel="nofollow" title="Share to Twitter">
                <img loading="lazy" src="https://photos5.appleinsider.com/v10/images/twitter.png" aria-hidden="true" alt="Twitter" />
                <span class="hidden-xs">Twitter</span>
              </a>
            </div>
            <div class="social-share reddit col-xs-2">
              <a href="http://www.reddit.com/submit?url=https://appleinsider.com/articles/22/11/22/asahi-linux-for-apple-silicon-has-come-a-long-way-in-a-few-months" rel="nofollow" title="Share to Reddit">
                <img loading="lazy" src="https://photos5.appleinsider.com/v10/images/reddit.png" aria-hidden="true" alt="Reddit" />
                <span class="hidden-xs">Reddit</span>
              </a>
            </div>
            <div class="social-share col-xs-2">&nbsp;</div>
          </div>

                    <div class="col-sm-12">
    <p style="font-size:.9em;">
        <em>
            AppleInsider may earn an affiliate commission on purchases made through links on our site.
        </em>
    </p>
</div>          <p class="col-sm-12 article-lead">Asahi, a project to bring Linux to the Apple Silicon <a href="https://appleinsider.com/inside/mac" title="Mac" data-kpt="1">Mac</a>, has released a new progress report that details expanded USB and peripheral support.<div class="col-sm-12"><figure><figcaption></figcaption></figure></div><div class="col-sm-12"><p>A project to port Linux to <a href="https://appleinsider.com/inside/apple-silicon" title="Apple Silicon" data-kpt="1">Apple Silicon</a> Macs, the <a href="https://asahilinux.org/2022/11/november-2022-report/">latest update</a> to Asahi Linux has new hardware support, new features, and fixes for "longstanding pain points." It also features a new bleeding-edge kernel branch with support for suspend and the display controller.</p></div><div class="col-sm-12"><p>The team reminds users to keep their Linux installations up to date. Early in the <a href="https://appleinsider.com/inside/macos-ventura" title="macOS Ventura" data-kpt="1">macOS Ventura</a> betas, they found an issue that would make Linux unbootable after the upgrade.</p></div><div class="col-sm-12"><p>A package update fixed the bug earlier in 2022. However, they still see users recently upgrading to macOS Ventura, or even the latest 12.x macOS releases, and end up with unbootable Linux installations.</p></div><div class="col-sm-12"><div class="primis-ad-wrap"></div></div><div class="col-sm-12"><h2 data-anchor="changes-in-asahi" id="changes-in-asahi">Changes in Asahi</h2></div><div class="col-sm-12"><p>The blog post is a lengthy one, with many new updates. Most of the updates pertain to peripherals, USB-C, and headphones.</p></div><div class="col-sm-12"><p>Until now, Asahi Linux has only supported USB 2.0 on the Thunderbolt ports. The team now believes that USB 3 support should be reasonably solid, but users should expect some glitches, particularly while quickly hotplugging devices. According to a headline in the post called "USB3, Chapter 2x7 Gen3.1415." this may include support for USB 3.1.</p></div><div class="col-sm-12"><p>However, users should be able to fix the glitches by disconnecting and reconnecting the device.</p></div><div class="col-sm-12"><p>Meanwhile, work continues supporting a Mac's speakers. The team needs to implement a safety model, so users don't blow out their speakers, as happened during testing. The speakers remain disabled, but progress is being made.</p></div><div class="col-sm-12"><p>But thanks to a reverse-engineering of a headphone codec used in newer Macs, Asahi now has headphone jack support.</p></div><div class="col-sm-12"><p>Support for keyboard backlighting is also included in the new update. However, the team is still working to support display brightness.</p></div><div class="col-sm-12"><p>It's a nice update to Asahi Linux, and users should be able to install it and get practical use out of it soon. Advanced Mac users can find installation instructions on the <a href="https://asahilinux.org/">Asahi Linux</a>.</p></div></p>

        </div>
        <hr class="hidden-lg hidden-xs">
      </div>
    </article>
  <div class="col-sm-4 comment-count visible-xs" role="complementary" aria-label="Article Comments">
          <span class="badge">
        <a href="https://forums.appleinsider.com/discussion/229725">
          1 Comments
          <span class="carrot" aria-hidden="true"></span>
        </a>
      </span>
      </div>
  
  <div class="hidden-xs">
    <hr>
  <!-- end right side upper half -->
    <!-- GPT AdSlot 2 for Ad unit '300x250_Article' ### Size: [[300,250]] -->
    <hr class="visible-xs">
    <div class="row ad hidden-xs" style="text-align: center;">
    <div id='div-gpt-ad-3649610-2'>
    </div>
    <!-- End AdSlot 2 -->
  </div>
  
      <aside class="row article-comments" style="overflow: hidden;">
    <div class="row">
            <h2 class="comment-section-head hidden-xs">Comments (1)</h2>
                                                <div class="col-sm-12 forum-comment">
    <div class="row">
        <a href="https://forums.appleinsider.com/profile/decoderring"><img loading="lazy" class="user-avatar" src="https://vanillicon.com/v2/69341baac8f7b7729fa6915daee51b8b.svg" alt="Forum User decoderring" style="display: inline-block;">
        <h2 style="display: inline-block;">decoderring</a></h2>
        <span>said about <time datetime="2022-11-23T00:13:20+00:00">16 hours ago</time></span>
        <p><p>I&rsquo;m eagerly watching the project progress.<br><br>I can&rsquo;t wait till it reaches a stage where it&rsquo;s ready for full-time driving with my usage needs.&nbsp;</p>
</p>
    </div>
    <hr>
</div>
                                        <div class="col-lg-12" style="text-align:right;">
                <a class="comments-read-more-link" href="https://forums.appleinsider.com/discussion/229725#first-reply" style="padding: 5px;">Read More on the forums...</a>
            </div>
            <div id="vanilla-comments">
                <script>
                    var vanilla_forum_url = 'https://forums.appleinsider.com/';
                    var vanilla_identifier = 'vanilla-comments';
                    var vanilla_discussion_id = '191948';

                    /*** DON'T EDIT BELOW THIS LINE ***/
                    (function() {
                        var vanilla = document.createElement('script');
                        vanilla.type = 'text/javascript';
                        var timestamp = new Date().getTime();
                        vanilla.src = vanilla_forum_url + '/js/embed.js';
                        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(vanilla); 
                    })();
                </script>
                <noscript>Please enable JavaScript to comment</noscript>
            </div>
    </div>
</aside>
    </div>
</div>
<!--  end left side upper half -->

<!-- right side upper half -->
  <div class="col-lg-3">
    <div class="visible-lg" style="padding-top:10px;">&nbsp;</div>

    <!-- Related Articles -->
    <div class="hidden-xs">
      <hr class="visible-md">
      <div class="col-xs-12">
        <h2 class="uc">Related Articles</h2>
        <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5 col-lg-12">
            <a href="https://appleinsider.com/articles/22/11/20/apple-fellow-phil-schiller-quits-twitter"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/51468-101849-42086-81568-0-78801-phil-4-xl-xl-m.jpg" alt="article thumbnail"></a>
            <br>
        </div>
        <div class="col-sm-8 col-xs-7 col-lg-12">
            <h2><a href="https://appleinsider.com/articles/22/11/20/apple-fellow-phil-schiller-quits-twitter">Apple Fellow Phil Schiller quits Twitter</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">Apple Fellow Phil Schiller has deactivated his account from Twitter, closing the account on Sunday for unknown reasons.</p>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5 col-lg-12">
            <a href="https://appleinsider.com/articles/22/11/19/tim-cook-attends-opening-of-adeles-las-vegas-residency"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/51461-101838-adele-vegas-m.jpg" alt="article thumbnail"></a>
            <br>
        </div>
        <div class="col-sm-8 col-xs-7 col-lg-12">
            <h2><a href="https://appleinsider.com/articles/22/11/19/tim-cook-attends-opening-of-adeles-las-vegas-residency">Tim Cook attends opening of Adele&#039;s Las Vegas residency</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">Apple CEO Tim Cook was in attendance at the opening night of Adele&#039;s Las Vegas residency on Friday, watching the singer start her run of performances.</p>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5 col-lg-12">
            <a href="https://appleinsider.com/articles/22/09/09/compared-new-apple-watch-se-vs-apple-watch-se-2020"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/50323-101789-DSC_2673-m.jpg" alt="article thumbnail"></a>
            <br>
        </div>
        <div class="col-sm-8 col-xs-7 col-lg-12">
            <h2><a href="https://appleinsider.com/articles/22/09/09/compared-new-apple-watch-se-vs-apple-watch-se-2020">Compared: New Apple Watch SE vs. Apple Watch SE 2020</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">Apple unveiled the second generation of the Apple Watch SE at Wednesday&#039;s &quot;Far Out&quot; event. Here&#039;s how it compares to its predecessor.</p>
        </div>
    </div>
</article>
<hr>
      </div>
    </div>
    <!-- end related articles -->

    <div class="boxes ad">
    <div class="box">
        <div id="div-gpt-ad-1587659960977-0" class="ad-halfp-mrec-mixed hidden-xs"></div>
        <div id="div-gpt-ad-1586972924313-0" class="ad-mrec visible-xs"></div>
    </div>
</div>
    <hr>

    <div class="hidden-xs">
      <article class="feat-deal2">
  <div class="row">
    <div class="col-xs-3 col-lg-6 avatar-link">
      <a href="https://appleinsider.com/deals/best-mac-studio-deals"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/embedables/76-hero.png" alt="Apple Mac Studio top view"></a>
    </div>
    <div class="col-xs-9 col-lg-6"><h2><a href="https://appleinsider.com/deals/best-mac-studio-deals">Exclusive Mac Studio deals</a></h2><span class="Stockdown">Save up to $150 on systems, $30 on AppleCare</span></div>
  </div>
</article>
<p></p>
<p></p>
<article class="feat-deal2">
  <div class="row">
    <div class="col-xs-3 col-lg-6 avatar-link">
      <a href="https://appleinsider.com/deals/best-ipad-deals"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/price_guide/ipad-air-5-pg-header.png" alt="2022 iPad Air 5 in Starlight"></a>
    </div>
    <div class="col-xs-9 col-lg-6"><h2><a href="https://appleinsider.com/deals/best-ipad-deals">Get an iPad for cheap</a></h2><span class="Stockdown">Prices as low as $279</span></div>
  </div>
</article>
<p></p>
<p></p>
<article class="feat-deal2">
  <div class="row">
    <div class="col-xs-3 col-lg-6 avatar-link">
      <a href="https://appleinsider.com/deals/best-macbook-air-deals"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/price_guide/m2-macbook-air-pg-header.png" alt="Apple MacBook Air with M2 in Midnight"></a>
    </div>
    <div class="col-xs-9 col-lg-6"><h2><a href="https://appleinsider.com/deals/best-macbook-air-deals">M2 MacBook Air sale</a></h2><span class="Stockdown">Save up to $150, plus $40 off AppleCare</span></div>
  </div>
</article>
    </div>
    <div class="hidden-xs">
      <hr>
      <div class="boxes ad">
    <div class="box">
        <div id="div-gpt-ad-1588086356674-0" class="ad-mrec">
        </div>
    </div>
</div>
<hr class="visible-xs">    </div>
    <div class="hidden-xs">
              <hr class="visible-md">
<h2 class="uc">
                
            Latest comparisons
    </h2>

    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/inside/ipad-pro/vs/compared-m2-ipad-pro-vs-m1-ipad-pro"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/50648-100945-2022-M2-iPad-Pro-VS-2021-M1-iPad-Pro!-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/inside/ipad-pro/vs/compared-m2-ipad-pro-vs-m1-ipad-pro">Compared: M2 iPad Pro vs M1 iPad Pro</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">Apple&#039;s 2022 update to the iPad Pro lineup introduces its newest Apple Silicon chip to its tablet range. Here&#039;s how the latest iPad Pro models compete against Apple&#039;s 2021 generation.</p>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/inside/ipad-pro/vs/compared-m2-ipad-pro-vs-microsoft-surface-pro-9"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/50980-100724-surface-pro-9-ipad-pro-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/inside/ipad-pro/vs/compared-m2-ipad-pro-vs-microsoft-surface-pro-9">Compared: M2 iPad Pro vs. Microsoft Surface Pro 9</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">Microsoft&#039;s Surface Pro 9 updates the Windows tablet with both Intel and ARM options, in a form that competes directly with Apple&#039;s iPad Pro lineup. Here&#039;s how the rival tablets square up.</p>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/inside/ipad/vs/comparison-new-109-inch-ipad-vs-ipad-air"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/50912-100538-iPad-vs-Air-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/inside/ipad/vs/comparison-new-109-inch-ipad-vs-ipad-air">Comparison: New 10.9-inch iPad vs. iPad Air</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">The redesigned entry-level 10.9-inch iPad is closer to the iPad Air than ever. Here&#039;s how they compare.</p>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/inside/m2-macbook-air/vs/compared-m2-macbook-air-versus-microsoft-surface-laptop-5"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/50849-100415-surface-laptop-5-m2-macbook-air-header-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/inside/m2-macbook-air/vs/compared-m2-macbook-air-versus-microsoft-surface-laptop-5">Compared: M2 MacBook Air versus Microsoft Surface Laptop 5</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">Microsoft&#039;s Surface Laptop 5 is a thin and powerful Windows notebook in the same market segment as Apple&#039;s MacBook Air. Here&#039;s how the two compare.</p>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/inside/airpods-pro-2/vs/compared-airpods-pro-2-vs-bose-quietcomfort-earbuds-ii"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/50839-100364-bose-airpods-header-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/inside/airpods-pro-2/vs/compared-airpods-pro-2-vs-bose-quietcomfort-earbuds-ii">Compared: AirPods Pro 2 vs. Bose QuietComfort Earbuds II</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">The Bose QuietComfort Earbuds II offer all of the comforts of noise-cancellation in a wireless package similar to the new AirPods Pro 2. Here&#039;s how the two flagship earbuds stack up.</p>
        </div>
    </div>
</article>
<hr>
          </div>
  </div>
  <!-- Dark mode support needs to be added to embed inside forums css to color correctly -->
  </div>

</div> <!-- /content -->

  <div id="topic-nav" class="hidden-xs fluid-container">
  <div class="container text-center">
  <nav class="nav" aria-label="Secondary">
      <ul>
        <li><a href="https://appleinsider.com/inside/iphone-14" title="iPhone 14">iPhone 14</a></li>
        <li><a href="https://appleinsider.com/inside/iphone-14-pro" title="iPhone 14 Pro">iPhone 14 Pro</a></li>
        <!-- <li><a href="https://appleinsider.com/deals/best-microsoft-365-and-office-for-mac-deals" title="Microsoft Office for Mac">Microsoft Office for Mac</a></li> -->
        <li><a href="https://appleinsider.com/deals/black-friday" title="Black Friday Deals">Black Friday Deals</a></li>
        <li><a href="https://appleinsider.com/inside/macbook-pro" title="MacBook Pro">MacBook Pro</a></li>
        <li><a href="https://appleinsider.com/inside/airpods" title="AirPods">AirPods</a></li>
        <li><a href="https://appleinsider.com/inside/ipad" title="iPad">iPad</a></li>
        <li class="hidden-sm"><a href="https://appleinsider.com/inside/mac-mini" title="Mac mini">Mac mini</a></li>
        <li class="hidden-sm"><a href="https://appleinsider.com/inside/macbook-air" title="MacBook Air">MacBook Air</a></li>
        <li><a href="https://appleinsider.com/inside" title="More...">More...</a>
      </ul>
    </nav>
  </div>
</div>

<div id="topic-nav-spacer" class="hidden-xs hidden-sm">&nbsp;</div>
  <div class="container">
      <div class="row" role="complementary" aria-label="Latest News">
        <h2 class="block-header uc">Latest News</h2>
        <div class="col-lg-9">
                      <article class="main-art river">
  <div class="row">
    <div class="col-sm-4 col-xs-5">
      <a href="https://appleinsider.com/articles/22/11/23/satechi-black-friday-2022-get-up-to-30-off-on-all-products"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/apps/ipad/images/articles/67856.jpg" alt="article thumbnail"></a>
      <img loading="lazy" class="avatar img-circle hidden-xs" src="https://photos5.appleinsider.com/gallery/appleinsider+staff.jpg" alt="author image">
    </div>
    <div class="col-sm-8 col-xs-7">
      <!-- phone view -->
      <div class="visible-xs">
                <p><a href="https://appleinsider.com/articles/22/11/23/satechi-black-friday-2022-get-up-to-30-off-on-all-products">Satechi Black Friday 2022: Get up to 30% off on all products</a></p>
        <span class="avatar-link"><time datetime="2022-11-23T16:08:34+00:00">28 minutes ago</time></span>
      </div>
      <!-- iPad and Desktop view -->
      <div class="row hidden-xs">
        <div class="col-sm-12">
          <h2 class="blueHover"><a href="https://appleinsider.com/articles/22/11/23/satechi-black-friday-2022-get-up-to-30-off-on-all-products">Satechi Black Friday 2022: Get up to 30% off on all products</a></h2>
                    Satechi is kicking off its Black Friday 2022 sale, including accessories for Mac and other Apple products.
        </div>
                <div class="col-sm-10 avatar-link river-author-byline">
          By <a href="https://appleinsider.com/editor/AppleInsider+Staff">AppleInsider Staff</a>  |  <time datetime="2022-11-23T16:08:34+00:00">28 minutes ago</time>
        </div>
        <div class="col-sm-2 river-comments">
                  </div>
      </div>
  </div>
  </div>
  <hr>
</article>
                      <article class="main-art river">
  <div class="row">
    <div class="col-sm-4 col-xs-5">
      <a href="https://appleinsider.com/articles/22/11/23/apple-tv-4k-dips-to-80-at-amazon-a-new-record-low-price-ahead-of-black-friday"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/apps/ipad/images/articles/67855.jpg" alt="article thumbnail"></a>
      <img loading="lazy" class="avatar img-circle hidden-xs" src="https://photos5.appleinsider.com/gallery/appleinsider+staff.jpg" alt="author image">
    </div>
    <div class="col-sm-8 col-xs-7">
      <!-- phone view -->
      <div class="visible-xs">
                <p><a href="https://appleinsider.com/articles/22/11/23/apple-tv-4k-dips-to-80-at-amazon-a-new-record-low-price-ahead-of-black-friday">Apple TV 4K dips to $80 at Amazon, a new record low price ahead of Black Friday</a></p>
        <span class="avatar-link"><time datetime="2022-11-23T15:23:30+00:00">1 hour ago</time></span>
      </div>
      <!-- iPad and Desktop view -->
      <div class="row hidden-xs">
        <div class="col-sm-12">
          <h2 class="blueHover"><a href="https://appleinsider.com/articles/22/11/23/apple-tv-4k-dips-to-80-at-amazon-a-new-record-low-price-ahead-of-black-friday">Apple TV 4K dips to $80 at Amazon, a new record low price ahead of Black Friday</a></h2>
                    Amazon&#039;s record-breaking Apple TV deal means you can get an Apple TV 4K set-top box for only $80.
        </div>
                <div class="col-sm-10 avatar-link river-author-byline">
          By <a href="https://appleinsider.com/editor/AppleInsider+Staff">AppleInsider Staff</a>  |  <time datetime="2022-11-23T15:23:30+00:00">1 hour ago</time>
        </div>
        <div class="col-sm-2 river-comments">
                  </div>
      </div>
  </div>
  </div>
  <hr>
</article>
                      <article class="main-art river">
  <div class="row">
    <div class="col-sm-4 col-xs-5">
      <a href="https://appleinsider.com/articles/22/11/23/black-friday-2022-get-discovery-plus-for-just-099-per-month-for-3-months"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/apps/ipad/images/articles/67854.jpg" alt="article thumbnail"></a>
      <img loading="lazy" class="avatar img-circle hidden-xs" src="https://photos5.appleinsider.com/gallery/appleinsider+staff.jpg" alt="author image">
    </div>
    <div class="col-sm-8 col-xs-7">
      <!-- phone view -->
      <div class="visible-xs">
                <p><a href="https://appleinsider.com/articles/22/11/23/black-friday-2022-get-discovery-plus-for-just-099-per-month-for-3-months">Black Friday 2022: Get Discovery Plus for just $0.99 per month for 3 months</a></p>
        <span class="avatar-link"><time datetime="2022-11-23T14:56:10+00:00">1 hour ago</time></span>
      </div>
      <!-- iPad and Desktop view -->
      <div class="row hidden-xs">
        <div class="col-sm-12">
          <h2 class="blueHover"><a href="https://appleinsider.com/articles/22/11/23/black-friday-2022-get-discovery-plus-for-just-099-per-month-for-3-months">Black Friday 2022: Get Discovery Plus for just $0.99 per month for 3 months</a></h2>
                    Ahead of Black Friday, Discovery Plus is offering a deal on its Ad-Lite plan, with customers able to pay just $0.99 per month for their first three months with the video streaming service.
        </div>
                <div class="col-sm-10 avatar-link river-author-byline">
          By <a href="https://appleinsider.com/editor/AppleInsider+Staff">AppleInsider Staff</a>  |  <time datetime="2022-11-23T14:56:10+00:00">1 hour ago</time>
        </div>
        <div class="col-sm-2 river-comments">
                  </div>
      </div>
  </div>
  </div>
  <hr>
</article>
                      <article class="main-art river">
  <div class="row">
    <div class="col-sm-4 col-xs-5">
      <a href="https://appleinsider.com/articles/22/11/23/aqaras-new-cube-t1-pro-adds-support-for-homekit"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/apps/ipad/images/articles/67853.jpg" alt="article thumbnail"></a>
      <img loading="lazy" class="avatar img-circle hidden-xs" src="https://photos5.appleinsider.com/gallery/andrew+orr.jpg" alt="author image">
    </div>
    <div class="col-sm-8 col-xs-7">
      <!-- phone view -->
      <div class="visible-xs">
                <p><a href="https://appleinsider.com/articles/22/11/23/aqaras-new-cube-t1-pro-adds-support-for-homekit">Aqara&#039;s new Cube T1 Pro adds support for HomeKit</a></p>
        <span class="avatar-link"><time datetime="2022-11-23T14:52:25+00:00">1 hour ago</time></span>
      </div>
      <!-- iPad and Desktop view -->
      <div class="row hidden-xs">
        <div class="col-sm-12">
          <h2 class="blueHover"><a href="https://appleinsider.com/articles/22/11/23/aqaras-new-cube-t1-pro-adds-support-for-homekit">Aqara&#039;s new Cube T1 Pro adds support for HomeKit</a></h2>
                    Smart home vendor Aqara has released the Cube T1 Pro, adding support for Homekit and a new Scene Mode.
        </div>
                <div class="col-sm-10 avatar-link river-author-byline">
          By <a href="https://appleinsider.com/editor/Andrew+Orr">Andrew Orr</a>  |  <time datetime="2022-11-23T14:52:25+00:00">1 hour ago</time>
        </div>
        <div class="col-sm-2 river-comments">
                    <a href="https://forums.appleinsider.com/discussion/229731"><span class="badge">1<span class="carrot" aria-hidden="true"></span></a>
                  </div>
      </div>
  </div>
  </div>
  <hr>
</article>
                      <article class="main-art river">
  <div class="row">
    <div class="col-sm-4 col-xs-5">
      <a href="https://appleinsider.com/inside/mac/tips/how-to-watch-paramount-on-a-mac"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/apps/ipad/images/articles/67852.jpg" alt="article thumbnail"></a>
      <img loading="lazy" class="avatar img-circle hidden-xs" src="https://photos5.appleinsider.com/gallery/andrew+orr.jpg" alt="author image">
    </div>
    <div class="col-sm-8 col-xs-7">
      <!-- phone view -->
      <div class="visible-xs">
                <p><a href="https://appleinsider.com/inside/mac/tips/how-to-watch-paramount-on-a-mac">How to watch Paramount+ on a Mac</a></p>
        <span class="avatar-link"><time datetime="2022-11-23T14:49:36+00:00">1 hour ago</time></span>
      </div>
      <!-- iPad and Desktop view -->
      <div class="row hidden-xs">
        <div class="col-sm-12">
          <h2 class="blueHover"><a href="https://appleinsider.com/inside/mac/tips/how-to-watch-paramount-on-a-mac">How to watch Paramount+ on a Mac</a></h2>
                    Paramount+ is one of multiple video streaming services offering content from several channels. Here&#039;s how to watch Paramount+ on a Mac.
        </div>
                <div class="col-sm-10 avatar-link river-author-byline">
          By <a href="https://appleinsider.com/editor/Andrew+Orr">Andrew Orr</a>  |  <time datetime="2022-11-23T14:49:36+00:00">1 hour ago</time>
        </div>
        <div class="col-sm-2 river-comments">
                  </div>
      </div>
  </div>
  </div>
  <hr>
</article>
                      <article class="main-art river">
  <div class="row">
    <div class="col-sm-4 col-xs-5">
      <a href="https://appleinsider.com/articles/22/11/23/daily-deals-nov-23-150-off-m2-macbook-air-apple-watch-ultra-for-739-25-off-nomad-goods-for-black-friday-more"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/apps/ipad/images/articles/67851.jpg" alt="article thumbnail"></a>
      <img loading="lazy" class="avatar img-circle hidden-xs" src="https://photos5.appleinsider.com/gallery/appleinsider+staff.jpg" alt="author image">
    </div>
    <div class="col-sm-8 col-xs-7">
      <!-- phone view -->
      <div class="visible-xs">
                <p><a href="https://appleinsider.com/articles/22/11/23/daily-deals-nov-23-150-off-m2-macbook-air-apple-watch-ultra-for-739-25-off-nomad-goods-for-black-friday-more">Daily deals Nov. 23: $150 off M2 MacBook Air, Apple Watch Ultra for $739, 25% off Nomad goods for Black Friday, more</a></p>
        <span class="avatar-link"><time datetime="2022-11-23T13:53:37+00:00">2 hours ago</time></span>
      </div>
      <!-- iPad and Desktop view -->
      <div class="row hidden-xs">
        <div class="col-sm-12">
          <h2 class="blueHover"><a href="https://appleinsider.com/articles/22/11/23/daily-deals-nov-23-150-off-m2-macbook-air-apple-watch-ultra-for-739-25-off-nomad-goods-for-black-friday-more">Daily deals Nov. 23: $150 off M2 MacBook Air, Apple Watch Ultra for $739, 25% off Nomad goods for Black Friday, more</a></h2>
                    Wednesday&#039;s best deals include $250 off 14-inch MacBook Pro, $150 for a Flexispot standing desk, 31% off AMD Ryzen 9 7950X desktop processor, and much more.
        </div>
                <div class="col-sm-10 avatar-link river-author-byline">
          By <a href="https://appleinsider.com/editor/AppleInsider+Staff">AppleInsider Staff</a>  |  <time datetime="2022-11-23T13:53:37+00:00">2 hours ago</time>
        </div>
        <div class="col-sm-2 river-comments">
                  </div>
      </div>
  </div>
  </div>
  <hr>
</article>
                      <article class="main-art river">
  <div class="row">
    <div class="col-sm-4 col-xs-5">
      <a href="https://appleinsider.com/articles/22/11/23/buy-10-mac-studios-or-this-one-macintosh-color-classic"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/apps/ipad/images/articles/67850.jpg" alt="article thumbnail"></a>
      <img loading="lazy" class="avatar img-circle hidden-xs" src="https://photos5.appleinsider.com/gallery/william+gallagher.jpg" alt="author image">
    </div>
    <div class="col-sm-8 col-xs-7">
      <!-- phone view -->
      <div class="visible-xs">
                <p><a href="https://appleinsider.com/articles/22/11/23/buy-10-mac-studios-or-this-one-macintosh-color-classic">Buy 10 Mac Studios, or this one Macintosh Color Classic</a></p>
        <span class="avatar-link"><time datetime="2022-11-23T12:51:06+00:00">3 hours ago</time></span>
      </div>
      <!-- iPad and Desktop view -->
      <div class="row hidden-xs">
        <div class="col-sm-12">
          <h2 class="blueHover"><a href="https://appleinsider.com/articles/22/11/23/buy-10-mac-studios-or-this-one-macintosh-color-classic">Buy 10 Mac Studios, or this one Macintosh Color Classic</a></h2>
                    For $20,000 you could be the one to buy an Apple Macintosh Color Classic originally bought in the early 1990s — and then never taken out of its box.
        </div>
                <div class="col-sm-10 avatar-link river-author-byline">
          By <a href="https://appleinsider.com/editor/William+Gallagher">William Gallagher</a>  |  <time datetime="2022-11-23T12:51:06+00:00">3 hours ago</time>
        </div>
        <div class="col-sm-2 river-comments">
                    <a href="https://forums.appleinsider.com/discussion/229730"><span class="badge">1<span class="carrot" aria-hidden="true"></span></a>
                  </div>
      </div>
  </div>
  </div>
  <hr>
</article>
                      <article class="main-art river">
  <div class="row">
    <div class="col-sm-4 col-xs-5">
      <a href="https://appleinsider.com/articles/20/11/23/how-to-watch-a-charlie-brown-thanksgiving-free-on-apple-tv-and-pbs"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/apps/ipad/images/articles/55911.jpg" alt="article thumbnail"></a>
      <img loading="lazy" class="avatar img-circle hidden-xs" src="https://photos5.appleinsider.com/gallery/william+gallagher.jpg" alt="author image">
    </div>
    <div class="col-sm-8 col-xs-7">
      <!-- phone view -->
      <div class="visible-xs">
                <p><a href="https://appleinsider.com/articles/20/11/23/how-to-watch-a-charlie-brown-thanksgiving-free-on-apple-tv-and-pbs">How to watch &#039;A Charlie Brown Thanksgiving&#039; free on Apple TV+</a></p>
        <span class="avatar-link"><time datetime="2022-11-23T12:10:00+00:00">4 hours ago</time></span>
      </div>
      <!-- iPad and Desktop view -->
      <div class="row hidden-xs">
        <div class="col-sm-12">
          <h2 class="blueHover"><a href="https://appleinsider.com/articles/20/11/23/how-to-watch-a-charlie-brown-thanksgiving-free-on-apple-tv-and-pbs">How to watch &#039;A Charlie Brown Thanksgiving&#039; free on Apple TV+</a></h2>
                    Although the famous Charlie Brown special will no longer air on ABC this Thanksgiving, it will be available on Apple TV+. Here&#039;s how and when to watch it for free.
        </div>
                <div class="col-sm-10 avatar-link river-author-byline">
          By <a href="https://appleinsider.com/editor/William+Gallagher">William Gallagher</a>  |  <time datetime="2022-11-23T12:10:00+00:00">4 hours ago</time>
        </div>
        <div class="col-sm-2 river-comments">
                  </div>
      </div>
  </div>
  </div>
  <hr>
</article>
                  </div>
        <div class="col-lg-3">
          <div class="visible-xs">
            <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5 col-lg-12">
            <a href="https://appleinsider.com/articles/22/11/20/apple-fellow-phil-schiller-quits-twitter"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/51468-101849-42086-81568-0-78801-phil-4-xl-xl-m.jpg" alt="article thumbnail"></a>
            <br>
        </div>
        <div class="col-sm-8 col-xs-7 col-lg-12">
            <h2><a href="https://appleinsider.com/articles/22/11/20/apple-fellow-phil-schiller-quits-twitter">Apple Fellow Phil Schiller quits Twitter</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">Apple Fellow Phil Schiller has deactivated his account from Twitter, closing the account on Sunday for unknown reasons.</p>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5 col-lg-12">
            <a href="https://appleinsider.com/articles/22/11/19/tim-cook-attends-opening-of-adeles-las-vegas-residency"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/51461-101838-adele-vegas-m.jpg" alt="article thumbnail"></a>
            <br>
        </div>
        <div class="col-sm-8 col-xs-7 col-lg-12">
            <h2><a href="https://appleinsider.com/articles/22/11/19/tim-cook-attends-opening-of-adeles-las-vegas-residency">Tim Cook attends opening of Adele&#039;s Las Vegas residency</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">Apple CEO Tim Cook was in attendance at the opening night of Adele&#039;s Las Vegas residency on Friday, watching the singer start her run of performances.</p>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5 col-lg-12">
            <a href="https://appleinsider.com/articles/22/09/09/compared-new-apple-watch-se-vs-apple-watch-se-2020"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/50323-101789-DSC_2673-m.jpg" alt="article thumbnail"></a>
            <br>
        </div>
        <div class="col-sm-8 col-xs-7 col-lg-12">
            <h2><a href="https://appleinsider.com/articles/22/09/09/compared-new-apple-watch-se-vs-apple-watch-se-2020">Compared: New Apple Watch SE vs. Apple Watch SE 2020</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">Apple unveiled the second generation of the Apple Watch SE at Wednesday&#039;s &quot;Far Out&quot; event. Here&#039;s how it compares to its predecessor.</p>
        </div>
    </div>
</article>
<hr>
          </div>
          <hr class="visible-md">
<h2 class="uc">
    Latest Videos
</h2>

    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/22/09/09/compared-new-apple-watch-se-vs-apple-watch-se-2020"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/50323-101789-DSC_2673-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/22/09/09/compared-new-apple-watch-se-vs-apple-watch-se-2020">Compared: New Apple Watch SE vs. Apple Watch SE 2020</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">Apple unveiled the second generation of the Apple Watch SE at Wednesday&#039;s &quot;Far Out&quot; event. Here&#039;s how it compares to its predecessor.</p>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/22/11/15/hands-on-with-emergency-sos-via-satellite-on-iphone-14"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/51392-101646-Satellite-Connecting-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/22/11/15/hands-on-with-emergency-sos-via-satellite-on-iphone-14">Hands on with Emergency SOS via Satellite on iPhone 14</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">Apple has officially released the ability to get in touch with emergency services by texting via satellite on iPhone 14. Here&#039;s how the service works and how you can test it yourself.</p>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/22/11/15/always-on-display-more-customizable-in-ios-162-beta-3"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/51398-101647-always-on-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/22/11/15/always-on-display-more-customizable-in-ios-162-beta-3">Always-on display more customizable in iOS 16.2 beta 3</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">Users will have the option to toggle off the wallpaper or notifications for the iPhone 14 Pro always-on display in iOS 16.2.</p>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/22/11/12/review-belkin-boostcharge-pro-wireless-car-charger-with-magsafe-delivers-the-juice"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/51263-101485-Charger-in-Jeep-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/22/11/12/review-belkin-boostcharge-pro-wireless-car-charger-with-magsafe-delivers-the-juice">Review: Belkin BoostCharge Pro Wireless Car Charger with MagSafe delivers the juice</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">Belkin introduced the world&#039;s first — and only — Apple-certified MagSafe car charger, but while it certainly delivers on speed, its connection method and price may give users pause.</p>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/22/11/08/hands-on-with-everything-new-in-ios-162-beta-2"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/51286-101340-Everything-New-in-iOS-162-Beta-2!-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/22/11/08/hands-on-with-everything-new-in-ios-162-beta-2">Hands on with everything new in iOS 16.2 beta 2</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">The second developer beta of iOS 16.2 has been released. We go hands on with all the new changes this time around.</p>
        </div>
    </div>
</article>
<hr>
 <!-- Videos Sidebar -->
          <div class="boxes ad">
    <div class="box">
        <div id="div-gpt-ad-1588174358438-0" class="ad-mrec">
        </div>
    </div>
</div>
<hr class="visible-xs">
          <hr class="visible-md">
<h2 class="uc">
    Latest Reviews
</h2>

    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/22/11/22/dbpower-portable-power-station-review-a-balance-of-utility-portability-and-price"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/51422-101896-DBPower-1-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/22/11/22/dbpower-portable-power-station-review-a-balance-of-utility-portability-and-price">DBPower Portable Power Station review: A balance of utility, portability, and price</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">The DBPower Portable Power Station isn&#039;t a perfect product, but it gets the job done with a tiny footprint and a relatively low price.</p>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/22/11/20/harber-everyday-briefcase-review-strong-and-attractive-protection-for-macbook-pro"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/51440-101879-000-lead-Harber-bag-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/22/11/20/harber-everyday-briefcase-review-strong-and-attractive-protection-for-macbook-pro">Harber Everyday Briefcase review: Strong and attractive protection for MacBook Pro</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">Don&#039;t throw it in with your airplane luggage, but the Harber Everyday Briefcase is a smart, extremely well-made, and roomy bag for carrying a MacBook Pro.</p>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/22/11/19/nuphy-halo65-wireless-mechanical-keyboard-review-a-small-keyboard-with-a-big-price-tag"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/51453-101816-IMG_1186-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/22/11/19/nuphy-halo65-wireless-mechanical-keyboard-review-a-small-keyboard-with-a-big-price-tag">Nuphy Halo65 Wireless Mechanical Keyboard review: a small keyboard with a big price tag</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">Nuphy&#039;s Halo65 is a mechanical wireless keyboard that&#039;s fairly compact and great to use, but its small size is countered by its premium pricing.</p>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/22/11/16/goal-zero-yeti-1000x-power-station-review-middling-specs-not-enough-ports-high-price"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/51340-101718-Goal-Zero-lede-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/22/11/16/goal-zero-yeti-1000x-power-station-review-middling-specs-not-enough-ports-high-price">Goal Zero Yeti 1000X power station review: Middling specs, not enough ports, high price</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">Modern portable power stations should meet some minimum requirements for consideration, and the Goal Zero Yeti 1000X struggles to meet any.</p>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/22/11/15/airversa-purelle-air-purifier-review-thread-connectivity-for-homekit-users"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/51351-101494-AirVersa-Purelle-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/22/11/15/airversa-purelle-air-purifier-review-thread-connectivity-for-homekit-users">AirVersa Purelle air purifier review: Thread connectivity for HomeKit users</a></h2>
            <p class="sidebar-md-desc hidden-lg hidden-xs">The AirVersa Purelle air purifier touts exclusive support for Apple HomeKit and benefits from its unique support for Thread connectivity.</p>
        </div>
    </div>
</article>
<hr>
 <!-- Reviews Sidebar -->
        </div>
      </div>
      <div class="col-lg-9" id="news-river"></div>
      <div class="col-lg-9" id="river-load-more" role="navigation" role="Load More Stories" data-current-page="1" data-href="/news/page/2">
    <div id="load-more">
        <a href="/news/page/2" id="load-more-link">
            <span id="load-more-link-text">Load More</span>
            <div class="ispinner ispinner--gray" style="display:none;">
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
            </div>
        </a>
    </div>
    <hr class="visible-lg visible-md">
</div>
  </div>
        </main>
        <!-- Jumbo ad accross site for large displays -->
        <div class="visible-xl desktop-sticky-rail ad">
            <div id="div-gpt-ad-3649610-1">&nbsp;</div>
        </div>
        <!-- New Footer -->
<div class="col-xs-12 footer-cont">
   <footer class="new-footer">
      <div class="col-sm-12 col-lg-12">
      <div class="row" style="padding-top: 40px; padding-bottom: 10px;">
         <div class="col-sm-offset-1">
            <img loading="lazy" src="https://photos5.appleinsider.com/v10/images/footer-ai-logo-2x.png" alt="AppleInsider Wordmark" width="184" height="55" />
         </div>
      </div>
      <div class="row" style="padding-bottom: 20px;">
         <form action="https://www.paypal.com/donate" method="post" target="_top" style="overflow:auto;">
            <input type="hidden" name="hosted_button_id" value="VFNTFTM4GJZ84" />
            <div class="col-xs-2 col-sm-1 col-sm-offset-1">
               <input type="image" src="https://pics.paypal.com/00/s/ZGU3Zjk3NjMtM2QzMi00ODI1LThlYzMtZDdiYTVlOTA5Y2Ez/file.PNG" border="0" 
                  name="submit" title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" style="display: inline-block; height: 40px;" />
            </div>
            <div class="col-xs-12 col-sm-8 col-sm-offset-1 col-lg-offset-0">
            <p class="hidden-xs" style="margin-left: 33px; font-size:.9em;">
               AppleInsider is one of the few truly independent online publications left.
               If you love what we do, please consider a small donation to help us keep the lights on.
            </p>
            <p class="visible-xs" style="font-size:.8em;">
               If you love AppleInsider and want to support independent publications, please consider a small donation.
            </p>
            </div>            
            <img alt="Donate to AppleInsider" border="0" src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1" />
         </form>
         </div>
      </div>
      <p class="col-sm-offset-1" style="padding-bottom: 1em;">
         Follow us on Social Media:
      </p>
      <div class="row" style="padding-bottom: 20px;">
      <div class="col-sm-12 col-lg-12">
         <div class="footer-socials col-sm-offset-1">
            <a href="https://www.facebook.com/AppleInsiderdotcom" title="AppleInsider on Facebook">
               <div class="footer-social-image-FB" aria-hidden="true"></div>
            </a>
            <a href="https://twitter.com/appleinsider" title="AppleInsider on Twitter">
               <div class="footer-social-image-T" aria-hidden="true"></div>
            </a>
            <a href="https://www.instagram.com/appleinsider" title="AppleInsider on Instragram">
               <div class="footer-social-image-E" aria-hidden="true"></div>
            </a>
            <a href="https://discord.gg/F4UFPVMhgM" title="Join the AppleInsider Discord Server">
               <div class="footer-social-discord" aria-hidden="true"></div>
            </a>
            <a href="https://www.linkedin.com/company/appleinsider" title="AppleInsider on LinkedIn">
               <div class="footer-social-linkedin" aria-hidden="true"></div>
            </a>
            <a href="https://www.youtube.com/appleinsider" title="Watch AppleInsider on YouTube">
               <div class="footer-social-youtube" aria-hidden="true"></div>
            </a>
         </div>
      </div>
      </div>
      <div class="row" style="padding-top:1rem; margin-top:1rem; border-top: 1px solid #282e37; padding-bottom:20px;">
         <div class="col-sm-6 col-xs-12 fine-print">
            Copyright &copy; 2022, Quiller Media, Inc.
         </div>
         <div class="col-xs-12 col-sm-6 fp-links fine-print" role="navigation" aria-label="Extra Links">
            <a href="https://appleinsider.com/advertising">Advertise on AI</a> | 
            <a href="https://appleinsider.com/contact">Contact Us</a> | 
            <a href="https://appleinsider.com/privacy">Privacy Policy</a> | 
            <a href="https://appleinsider.com/terms-of-use">Terms of Use</a>
            <h3>Designed by <a href="https://www.craftedny.com">Crafted</a></h3>
         </div>
      </div>
   </footer>
</div>

        <!-- Google Analytics -->
        <script async>
            !function(A,n,g,u,l,a,r){A.GoogleAnalyticsObject=l,A[l]=A[l]||function(){
            (A[l].q=A[l].q||[]).push(arguments)},A[l].l=+new Date,a=n.createElement(g),
            r=n.getElementsByTagName(g)[0],a.src=u,r.parentNode.insertBefore(a,r)
            }(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

            ga('create', 'UA-280331-5');
            ga('send', 'pageview');
        </script>

        <script defer src="https://photos5.appleinsider.com/v10/js/vendor.js?id=7232f4f9b9a4c92135d4"></script>
        <script defer src="https://photos5.appleinsider.com/v10/js/app.js?id=51240e6f718092b554ca"></script>

        <!-- Page Footer Scripts -->
          <template id="river-template">
<article class="main-art river">
  <div class="row">
    <div class="col-sm-4 col-xs-5">
      <a href="{{ link }}"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/apps/ipad/images/articles/{{id}}.jpg" alt="article thumbnail"></a>
      <img loading="lazy" class="avatar img-circle hidden-xs" src="{{ authorImage }}" alt="author profile image">
    </div>
    <div class="col-sm-8 col-xs-7">
      <div class="visible-xs">
        <p><a href="{{ link }}">{{ title }}</a></p>
        <span class="avatar-link"><time datetime="{{ isoDate }}">{{ dateFormatted }}</time></span>
      </div>
      <div class="row hidden-xs">
        <div class="col-sm-12">
          <h2 class="blueHover"><a href="{{ link }}">{{ title }}</a></h2>
          {{ summary }}
        </div>
        {{{ reviewStars.html }}}
        <div class="col-sm-10 avatar-link river-author-byline">
          By <a href="{{ authorLink }}">{{ author }}</a>  |  <time datetime="{{ isoDate }}">{{ dateFormatted }}</time>
        </div>
        <div class="col-sm-2 river-comments">
          <a href="{{ commentsLink }}"><span class="badge">{{ commentCount }}<span class="carrot" aria-hidden="true"></span></a>
        </div>        
      </div>
    </div>
  </div>
  <hr>
</article>
</template>
  <template id="river-ad-template">
    <div class="ad-mrec river-ad" style="overflow: hidden; margin-bottom: 10px;">
    </div>
    <script>
        riverSlots = [];
        riverAdCb = Math.round(new Date().getTime());
        reverAdCurEl = $('.river-ad:last');
        reverAdCurName = "ad-river-"+riverAdCb;
        reverAdCurEl.append('<div id="'+reverAdCurName+'" class="ad-mrec"></div>');

        if(googletag.defineSlot){
            riverSlots.push( googletag.defineSlot('/53013535/Load_More_News_River_Pop_300x250', [300, 250], reverAdCurName)
                .setTargeting('sub_section', Appleinsider.subSection)
                .setTargeting('sub_section', Appleinsider.subSectionTarget)
                .addService(googletag.pubads())
            );

            googletag.cmd.push(function() { googletag.display(reverAdCurName); });
            googletag.pubads().refresh(riverSlots, {changeCorrelator: false});
        } else {
            console.log('googletag not set. Ad blocker?');
        }
    </script>
</template>
  <script src="https://photos5.appleinsider.com/v10/js/article.js?id=56eb9f5813552ef8bf01"></script>
  
  <script type="text/template" id="coupon-overlay-template">
    <div id="pg-coupon-overlay">
      <div>
        <div style="text-align:center; margin-bottom:10px;"><img src="{IMG}"></div>
        <h2 class="fauxh1" style="padding-bottom:10px;"><a href="{LINK}">{LINK_TEXT}</a></h2>
      </div>
      <div>
        <p style="padding-bottom:10px;">{COUPON_INSTRUCTIONS}</p>
        <a id="coupon-overlay-buy" class="blue-light" href="{LINK}">Buy Now</a>
      </div>
    </div>
  </script>

  <script>
    //price guide embed coupon clicks.
    $(document).on('click', '.symbol', function(e){
        let link = $(this).attr('data-link');
        let img = $("#guide-image").attr("src");
        let title = $(this).parents("tr").children("td.item-desc:first")[0].innerHTML;
        let instructions = $(this).siblings(".tool-tip p:first")[0].innerHTML;
        let template = $('#coupon-overlay-template').text();
        
        template = template.replaceAll('{LINK_TEXT}', title);
        template = template.replaceAll('{LINK}', link);
        template = template.replace('{IMG}', img);
        template = template.replace('{COUPON_INSTRUCTIONS}', instructions);

        if(typeof link !== 'undefined'){
          $(this).colorbox({
              html: template,
              open: true,
              showClose: true,
              opacity: .9,
              width: "98%",
              height: "98%",
              top: "25%",
              transition: 'none'
          });

          e.preventDefault();
        }
    });
  </script>
  <script>
    $(window).on('scroll', function(e){
      if( $(window).scrollTop() > 200 && $('#header-deal-overlay')) {
        $('#header-deal-overlay').show();
        $('#header-deal-overlay').removeClass('doHide').addClass('doShow');
      }

      if( $(window).scrollTop() < 200 && $('#header-deal-overlay')) {
        $('#header-deal-overlay').addClass('doHide').removeClass('doShow');
        $('#header-deal-overlay').hide();
      }
    });
  </script>
  <script type="text/javascript">
      (function (window, document, accountId) {
        window.skimlinks_exclude = ["shop-links.co", "shop-edits.co"];
        window.NRTV_EVENT_DATA = { donotlink: true };

        var b = document.createElement("script");
        b.type = "text/javascript";
        b.src = "https://static.narrativ.com/tags/narrativ-pub.1.0.0.js";
        b.async = true;
        b.id = 'nrtvTag';
        b.setAttribute('data-narrativ-id', accountId);
        var a = document.getElementsByTagName("script")[0];
        a.parentNode.insertBefore(b, a);
      })(window, document, 1768);
  </script>
  <script id="funnel-relay-installer" data-property-id="PROPERTY_ID" data-customer-id="appleinsider_b7ac1_appleinsider" src="https://cdn-magiclinks.trackonomics.net/client/static/v2/appleinsider_b7ac1_appleinsider.js" async="async"></script>
  
  <script type="text/javascript">
  $(function(){
    $('.deal-accordion a.see-more').on( 'click', function(e){
      let id = $(this).parent('div:first').attr('id');
      let styleId = '#'+id+'-style';
      
      $(styleId).remove();
      $(this).remove();

      e.preventDefault();
    });

    $('.hero-caption').on('click',function(e){
      $(this).toggleClass('open');
    });
  });
  </script>
        <!-- End Page Footer Scripts -->

        <!-- Quantcast Tag -->
        <script async type="text/javascript">
            window._qevents = window._qevents || [];
            (function() {
                var elem = document.createElement('script');
                elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
                elem.async = true;
                elem.type = "text/javascript";
                var scpt = document.getElementsByTagName('script')[0];
                scpt.parentNode.insertBefore(elem, scpt);
                })();

                window._qevents.push({
                qacct:"p-dGYBJRHHExURr",
                uid:"jason@appleinsider.com"
            });
        </script>
        <noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-dGYBJRHHExURr.gif" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>       
        <!-- End Quantcast tag -->

        <!-- Start MS Clarify -->
        <script async type="text/javascript">
            (function(c,l,a,r,i,t,y){
                c[a]=c[a]||function(){(c[a].q=c[a].q||[]).push(arguments)};
                t=l.createElement(r);t.async=1;t.src="https://www.clarity.ms/tag/"+i;
                y=l.getElementsByTagName(r)[0];y.parentNode.insertBefore(t,y);
            })(window, document, "clarity", "script", "bk0zs5siy4");
        </script>
        <!-- End MS Clarify -->
    </body>
</html>
