<!doctype html>
<html lang="en">
    <head>
        <meta charset="utf-8">
        <title>Ten years of Apple technology shifts made the ARM Mac possible | Appleinsider</title>
        <meta name="description" content="Apple&#039;s transition to Macs with proprietary ARM chips may soon be officially acknowledged, but there have been clear and definite signs of the switch for years.">
        <meta name="keywords" content="Apple, Apple Inc, iPhone, iPad, iPod touch, iPod nano, Apple TV, Apple, iPod shuffle, iphone 6, iphone 6s, ios 9, ios9, iTunes, i mac, mac os x, mac osx, Apple Computer, Apple Computer Inc., Mac OS X, iMac, iBook, Mac Pro, MacBook Pro, Magic Pad, Magic Mouse, iPod classic, App Store, iTunes Store, iBook Store, mac book, Microsoft, Adobe, Research in Motion, RIM, Nokia, Samsung, Google, Nvidia, Intel">
        <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
        <!-- <meta name="google-site-verification" content="q6PMZEoYnsa-kIjsSGfwD9SONWR3UcUCH6Djz7pmhQs"> -->
        <meta name="google-site-verification" content="p84Cqvyr9UB11ipMY8Bmt_X7K69Ay95_1EQ_BwRgU1c">
        <meta name="robots" content="index,follow">
        <meta property="fb:pages" content="135590163123753">
        <meta name="apple-mobile-web-app-title" content="AppleInsider">
		<link rel="apple-touch-icon" sizes="57x57" href="https://photos5.appleinsider.com/v9/images/apple-touch-icon-57.png">
		<link rel="apple-touch-icon" sizes="72x72" href="https://photos5.appleinsider.com/v9/images/apple-touch-icon-72.png">
		<link rel="apple-touch-icon" sizes="114x114" href="https://photos5.appleinsider.com/v9/images/apple-touch-icon-114.png">
		<link rel="apple-touch-icon" sizes="144x144" href="https://photos5.appleinsider.com/v9/images/apple-touch-icon-144.png">
		<link rel="apple-touch-icon" href="https://photos5.appleinsider.com/v9/images/apple-touch-icon-144.png">
        
        <link rel="alternate" type="application/rss+xml" href="/appleinsider.rss" title="AppleInsider News">
        <link rel="canonical" href="https://appleinsider.com/articles/20/06/12/ten-years-of-apple-technology-shifts-made-the-arm-mac-possible">
        <link rel="stylesheet" href="https://photos5.appleinsider.com/v10/css/vendor.css?id=1e42fc323042544663c5">
        <link rel="stylesheet" href="https://photos5.appleinsider.com/v10/css/app.css?id=715e7328d49fd3f8179c">
          <link rel="amphtml" href="https://appleinsider.com/articles/20/06/12/ten-years-of-apple-technology-shifts-made-the-arm-mac-possible/amp/" />
  <meta property="og:url" content="https://appleinsider.com/articles/20/06/12/ten-years-of-apple-technology-shifts-made-the-arm-mac-possible"/>
  <meta property="og:image" content="https://photos5.appleinsider.com/gallery/36149-67066-49720773601_e3d33d50ec_k-xl.jpg"/>
  <meta property="og:title" content="Ten years of Apple technology shifts made the ARM Mac possible | Appleinsider"/>
  <meta property="og:description" content="Apple&#039;s transition to Macs with proprietary ARM chips may soon be officially acknowledged, but there have been clear and definite signs of the switch for years."/>
  <meta property="fb:app_id" content="908219582587578" />
  <meta property="og:type" content="website" /> 
  <meta property="og:locale" content="en_US" /> 
  <meta property="og:site_name" content="AppleInsider" /> 
  <meta name="twitter:card" content="summary_large_image" /> 
  <meta name="twitter:site" content="@appleinsider" /> 
  <meta name="twitter:creator" content="@appleinsider" /> 
  <meta name="twitter:domain" content="appleinsider.com" /> 
  <meta name="twitter:title" content="Ten years of Apple technology shifts made the ARM Mac possible | Appleinsider" /> 
  <meta name="twitter:description" content="Apple&#039;s transition to Macs with proprietary ARM chips may soon be officially acknowledged, but there have been clear and definite signs of the switch for years." /> 
  <meta name="twitter:image" content="https://photos5.appleinsider.com/gallery/36149-67066-49720773601_e3d33d50ec_k-xl.jpg" /> 
  <meta name="twitter:url" content="https://appleinsider.com/articles/20/06/12/ten-years-of-apple-technology-shifts-made-the-arm-mac-possible" /> 
        		<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
		<script>
		  window.googletag = window.googletag || {cmd: []};
		  googletag.cmd.push(function() {
            googletag.defineSlot('/53013535/Homepage_Desktop_Third_Rectangle_300x250', [300, 250], 'div-gpt-ad-1588086356674-0').addService(googletag.pubads());
            googletag.defineSlot('/53013535/Homepage_Mobile_Desktop_Mid_News_Rive_300x250', [300, 250], 'div-gpt-ad-1588086901643-0').addService(googletag.pubads());
            googletag.defineSlot('/53013535/Article_Bottom_Desktop_300x250', [300, 250], 'div-gpt-ad-1588174358438-0').addService(googletag.pubads());
            googletag.defineSlot('/53013535/homepage_article_top_rectangle_300x250_300x600', [[300, 250], [300, 600]], 'div-gpt-ad-1587659960977-0').addService(googletag.pubads());
            googletag.defineSlot('/53013535/Homepage_Sidebar_Medium_Rectangle_Top_300x250', [300, 250], 'div-gpt-ad-1586438946709-0').addService(googletag.pubads());
            googletag.defineSlot('/53013535/Homepage_Article_Mobile_Prime_Rectangle_300x250', [300, 250], 'div-gpt-ad-1586972924313-0').addService(googletag.pubads());
            googletag.defineSlot('/53013535/Homepage_Leaderboard_970x250_728x90', [[728, 90], [970, 250]], 'div-gpt-ad-1588083483022-0').addService(googletag.pubads());
            googletag.defineSlot('/53013535/Homepage_Mobile_Leaderboard_320x50_300x50', [320, 50], 'div-gpt-ad-1587678922868-0').addService(googletag.pubads());
            //googletag.pubads().enableSingleRequest();
            googletag.pubads().collapseEmptyDivs();
            googletag.enableServices();
		  });
		</script>
              <script type="application/ld+json">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</script>
      </head>

    <body>
        <!--[if lte IE 8]>
        <p class="browsehappy">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> to improve your experience.</p>
        <![endif]-->
        <header class="header header-desktop hidden-xs">
    <nav class="navbar navbar-default hidden-xs" id="desktop-nav">
        <div class="container">
            <div class="col-sm-1 header-bookend">
                <a href="https://appleinsider.com"><img loading="lazy" src="https://photos5.appleinsider.com/v10/images/logo.png" alt="AppleInsider logo"></a>
            </div>

            <div class="col-sm-10 text-center">
                <ul class="nav navbar-nav">
                    <li class="inl"><a href="https://appleinsider.com">News</a></li>
                    <li class="inl"><a href="https://appleinsider.com/reviews">Reviews</a></li>
                    <li class="inl"><a href="https://appleinsider.com/videos">Videos</a></li>
                    <li class="inl"><a href="https://deals.appleinsider.com">Deals</a></li>
                    <li class="inl dropdown dt-dd">
                        <button class="dropdown-toggle" type="button" data-toggle="dropdown">
                            <span class="uc">Price Guides</span> <span class="caret"></span>
                        </button>
                        <ul class="dropdown-menu dt-dd">
                            <li><a href="https://prices.appleinsider.com">All</a></li>
                            <li><a href="https://prices.appleinsider.com/current-gen">New Macs</a></li>
                            <li><a href="https://prices.appleinsider.com/ipad">iPads</a></li>
                            <li><a href="https://prices.appleinsider.com/apple-watch">Apple Watch</a></li>
                            <li><a href="https://prices.appleinsider.com/iphone">iPhones</a></li>
                            <li><a href="https://prices.appleinsider.com/wireless">Apple TV &amp; Accessories</a></li>
                            <li><a href="https://prices.appleinsider.com/music">AirPods &amp; Homepods</a></li>
                            <li><a href="https://prices.appleinsider.com/trade-in">iPhone &amp; iPad Trade-in Prices</a></li>
                        </ul>
                    </li>
                    <li class="inl"><a href="https://appleinsider.com/podcast">Podcast</a></li>
                    <li class="inl"><a href="https://forums.appleinsider.com">Forums</a></li>
                    <li class="inl"><a href="https://appleinsider.com/contact">Tip Us</a></li>
                    <li class="inl hidden-xs hidden-sm hidden-md stock-ticker">
                        <!--
<div class="navbar-left secondNavLeft">
</div> -->

AAPL: 338.8 ( <span class="Stockup">
+2.9</span> )
                    </li>
                </ul>
            </div>

            <div class="col-sm-1 header-bookend" style="height:58px;">
                <div class="btn-group">
                    <button type="button" class="btn btn-default dropdown-toggle search-btn" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
                        <span class="glyphicon glyphicon-search mobile-search-glyph" aria-hidden="true"></span>
                    </button>
                    <div class="dropdown-menu dropdown-right-custom">
                        <div class="container">
                            <form class="navbar-form navbar-left search-mobile" role="search" action="/search/">
                                <div class="form-group">
                                    <div class="box">
                                        <span class="glyphicon glyphicon-search mobile-search-glyph" aria-hidden="true"></span>
                                    </div>
                                    <div class="box search-input">
                                        <input type="text" class="form-control" id="search-in-dt" name="query" placeholder="Search AppleInsider" data-kpxc-id="kpxcpw342845639">
                                    </div>
                                    <span class="box glyphicon glyphicon-remove mobile-remove-glyph" aria-hidden="true"></span>
                                </div>
                            </form>
                        </div>
                    </div>
                </div>
            </div>
        </div>
    </nav>
</header>
<div class="push">&nbsp;</div>
<!-- End Desktop Nav -->


<!-- Begin Mobile Nav -->
<nav class="navbar navbar-default navbar-fixed-top visible-xs" style="max-width:100%">
    <div class="container" style="max-width:100%;">
        <div class="row navbar-header">
            <div class="col-xs-3">
                <button id="nav-toggle" type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#js-navbar-collapse">
                    <span class="collapsed-nav"> <span class="sr-only">Toggle navigation</span> <span class="icon-bar"></span> <span class="icon-bar"></span> </span> <span class="open-nav"> <img loading="lazy" src="https://photos5.appleinsider.com/v10/images/navClose.png" alt="Close Nav"></span>
                </button>
            </div>
            <div class="col-xs-6 hidden-md hidden-lg hidden-sm">
                <a class="center-block text-center" href="https://appleinsider.com"><img loading="lazy" class="mobile-logo" src="https://photos5.appleinsider.com/v10/images/Logo_mobile.png" alt="AppleInsider Logo"></a>
            </div>
            <div class="col-xs-3 text-right">
                <div class="btn-group search-bar-mobile">
                    <button type="button" class="btn btn-default dropdown-toggle search-btn" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
                        <span class="glyphicon glyphicon-search mobile-search-glyph" aria-hidden="true"></span>
                    </button>
                    <div class="dropdown-menu dropdown-right-custom">
                        <div class="container">
                            <div class="row">
                                <div class="col-xs-12">
                                    <form class="navbar-form navbar-left search-mobile" tabindex="1" role="search" action="/search/">
                                        <div class="form-group">
                                            <div class="boxes">
                                                <div class="box"> <span class="glyphicon glyphicon-search mobile-search-glyph" aria-hidden="true"></span></div>
                                                <div class="box search-input"> <input type="text" id="search-in-mob" class="form-control" name="query" placeholder="Search AppleInsider"></div>
                                                <div class="box closeSearch"> <span class="glyphicon glyphicon-remove mobile-remove-glyph" aria-hidden="true"></span></div>
                                            </div>
                                        </div>
                                    </form>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div>

            <div class="collapse navbar-collapse" id="js-navbar-collapse" style="width:100%;">
                <div class="container">
                    <div class="row">
                        <ul class="nav navbar-nav mobile-sett">
                            <li style="border-bottom:1px solid var(--primary-nav-hr);"><a href="https://appleinsider.com">News</a></li>
                            <li class="dropdown">
                                <a href="#" class="dropdown-toggle mobile-topics-subnav subnav-adjust" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">
                                    <div class="col-xs-11 subnav-adjust">Future Products</div>
                                    <div class="col-xs-1 subnav-adjust"><span class="glyphicon glyphicon-chevron-down"></span></div>
                                </a>
                                <ul class="dropdown-menu mobile-sett mobile-subnav">
                                    <li><a href="https://appleinsider.com/inside/iphone-12">iPhone 12</a></li>
                                    <li><a href="https://appleinsider.com/inside/ios-14">iOS 14</a></li>
                                    <li><a href="https://appleinsider.com/inside/iphone-se">iPhone SE</a></li>
                                    <li><a href="https://appleinsider.com/inside/mac-pro">Mac Pro</a></li>
                                    <li><a href="https://appleinsider.com/inside/airtags">AirTags</a></li>
                                    <li><a href="https://appleinsider.com/inside/14-inch-macbook-pro">14" MacBook Pro</a></li>
                                    <li><a href="https://appleinsider.com/inside/airpods-pro">AirPods Pro</a></li>
                                    <li><a href="https://appleinsider.com/inside/arm-mac">ARM MacBooks</a></li>
                                    <li><a href="https://appleinsider.com/inside/apple-watch-series-6">Apple Watch Series 6</a></li>
                                    <li><a href="https://appleinsider.com/inside/apple-glass">Apple Glass</a>
                                    <li><a href="https://appleinsider.com/inside/airpower">AirPower</a>
                                </ul>
                            </li>
                            <li><a href="https://appleinsider.com/reviews">Reviews</a></li>
                            <li><a href="https://appleinsider.com/videos">Videos</a></li>
                            <li><a href="https://deals.appleinsider.com">Deals</a></li>

                            <li class="dropdown">
                                <a href="#" class="dropdown-toggle mobile-topics-subnav subnav-adjust" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">
                                    <div class="col-xs-11 subnav-adjust">Price Guides</div>
                                    <div class="col-xs-1 subnav-adjust"><span class="glyphicon glyphicon-chevron-down"></span></div>
                                </a>
                                <ul class="dropdown-menu mobile-sett mobile-subnav">
                                    <li><a href="https://prices.appleinsider.com">All</a></li>
                                    <li><a href="https://prices.appleinsider.com/current-gen">New Macs</a></li>
                                    <li><a href="https://prices.appleinsider.com/ipad">iPads</a></li>
                                    <li><a href="https://prices.appleinsider.com/apple-watch">Apple Watch</a></li>
                                    <li><a href="https://prices.appleinsider.com/iphone">iPhones</a></li>
                                    <li><a href="https://prices.appleinsider.com/wireless">Apple TV &amp; Accessories</a></li>
                                    <li><a href="https://prices.appleinsider.com/music">AirPods &amp; Homepods</a></li>
                                    <li><a href="https://prices.appleinsider.com/trade-in">iPhone &amp; iPad Trade-in Prices</a></li>
                                </ul>
                            </li>
                            <li><a href="https://appleinsider.com/podcast">Podcast</a></li>
                            <li><a href="https://forums.appleinsider.com">Forums</a></li>
                            <li><a href="https://appleinsider.com/submit_story">Tip Us</a></li>
                        </ul>
                    </div>

                    <div class="row" style="margin-top: 15px; margin-bottom:15px;">
                        <div class="col-xs-3"></div>
                        <div class="col-xs-6">
                            <div class="col-xs-4"> <a href="https://twitter.com/appleinsider"><img loading="lazy" class="social" src="https://photos5.appleinsider.com/v10/images/ai-twitter.svg" alt="Twitter"></a> </div>
                            <div class="col-xs-4 text-center"> <a href="https://www.facebook.com/AppleInsiderdotcom"><img loading="lazy" class="social" src="https://photos5.appleinsider.com/v10/images/ai-facebook.svg" alt="Facebook"></a> </div>
                            <div class="col-xs-4 text-right"> <a href="https://www.instagram.com/appleinsider_official/"><img loading="lazy" class="social" src="https://photos5.appleinsider.com/v10/images/ai-instagram.svg" alt="Instagram"></a> </div>
                        </div>
                        <div class="col-xs-3"></div>
                    </div>

                    <div class="row">
                        <div class="col-xs-12" style="text-align: center; padding-bottom: 15px;">
                            <!--
<div class="navbar-left secondNavLeft">
</div> -->

AAPL: 338.8 ( <span class="Stockup">
+2.9</span> )
                        </div>
                    </div>

                    <div class="row">
                        <div class="col-xs-12 mobile-footer"> 
                            <p>Copyright &copy; 2020, Quiller Media, Inc.</p>
                            <p> <a href="https://appleinsider.com/contact">Contact Us</a> | <a href="https://appleinsider.com/privacy">Privacy Policy</a> | <a href="https://appleinsider.com/advertising">Advertise on AI</a></p>
                        </div>
                    </div>
                </div>
            </div>

        </div>
    </div>    
</nav>
<!-- End Mobile Nav -->

<!-- Super leaderboard Ad -->
<div class="container-fluid ad-wrap block-wrap">
    <div id="div-gpt-ad-1588083483022-0" class="ad-leaderboard hidden-xs">
        <script>
            googletag.cmd.push(function() { googletag.display('div-gpt-ad-1588083483022-0'); });
        </script>
    </div>
    <div id="mobile-ad-wrap" class="visible-xs">
        <div id="div-gpt-ad-1587678922868-0" class="ad-leaderboard visible-xs">
            <script>
                googletag.cmd.push(function() { googletag.display('div-gpt-ad-1587678922868-0'); });
            </script>
        </div>
    </div>
</div>

<div class="container" id="top-half-snap">
    <div class="row main-page">
         <!-- ************************** Left Side Upper half ************************** -->
 <div class="col-lg-9">
  <main>
    <article class="reviews">
      <div class="row">
        <div class="col-sm-12">
                      <h3><span class="feat">Feature</span></h3>
                  </div>
        <div class="col-sm-12">
          <h1 class="h1-adjust">Ten years of Apple technology shifts made the ARM Mac possible</h1>
        </div>
                  <div class="row article-hero-social">
  <div class="col-sm-8">
    <div class="avatar-link no-gutters">
      <img loading="lazy" class="avatarLG-article img-circle no-left-gutters" src="https://photos5.appleinsider.com/gallery/mike+peterson.jpg" alt="author image">
      By <a href="https://appleinsider.com/editor/Mike+Peterson">Mike Peterson</a>
      <span class="hidden-xs"> | 18 hours ago</span>
      <div class="visible-xs" style="margin-left: 66px; margin-top: -18px;">18 hours ago</div>
    </div>
  </div>
</div>
                <div class="row">
          <div class="col-sm-12" id="article-hero">
            <img loading="lazy" src="https://photos5.appleinsider.com/gallery/36149-67066-49720773601_e3d33d50ec_k-xl.jpg" alt="article thumbnail">
          </div>
          <div class="col-sm-12" id="article-social">
          <div class="social-share col-xs-2">&nbsp;</div>
                        <div class="social-share comments col-xs-2">
              <a href="https://forums.appleinsider.com/discussion/216207" title="Read Comments">
                <span class="glyphicon glyphicon-comment">&nbsp;</span>
                <span class="hidden-xs">11 Comments</span>
              </a>
            </div>
                        <div class="social-share facebook col-xs-2">
              <a href="https://www.facebook.com/sharer/sharer.php?u=https://appleinsider.com/articles/20/06/12/ten-years-of-apple-technology-shifts-made-the-arm-mac-possible" title="Share to Facebook">
              <img loading="lazy" src="https://photos5.appleinsider.com/v10/images/facebook.png" alt="Facebook"/><span class="hidden-xs">Facebook</span>
              </a>
            </div>
            <div class="social-share twitter col-xs-2">
              <a href="https://twitter.com/intent/tweet?original_referer=https://appleinsider.com/articles/20/06/12/ten-years-of-apple-technology-shifts-made-the-arm-mac-possible&text=Ten years of Apple technology shifts made the ARM Mac possible&url=https://appleinsider.com/articles/20/06/12/ten-years-of-apple-technology-shifts-made-the-arm-mac-possible" title="Share to Twitter">
                <img loading="lazy" src="https://photos5.appleinsider.com/v10/images/twitter.png" alt="Twitter" />
                <span class="hidden-xs">Twitter</span>
              </a>
            </div>
            <div class="social-share reddit col-xs-2">
              <a href="http://www.reddit.com/submit?url=https://appleinsider.com/articles/20/06/12/ten-years-of-apple-technology-shifts-made-the-arm-mac-possible" title="Share to Reddit">
                <img loading="lazy" src="https://photos5.appleinsider.com/v10/images/reddit.png" alt="Reddit" />
                <span class="hidden-xs">Reddit</span>
              </a>
            </div>
            <div class="social-share col-xs-2">&nbsp;</div>
          </div>
                              <div class="col-sm-12"><p>Apple's transition to Macs with proprietary ARM chips may soon be officially acknowledged, but there have been clear and definite signs of the switch for years.</p><div class="col-sm-12"><div class="align-center"></div></div><div class="col-sm-12"><p>A recent report indicated that Apple could <a href="https://appleinsider.com/articles/20/06/09/arm-mac-shift-said-to-be-announced-at-2020-wwdc">announce the impending change</a> at its <a href="https://appleinsider.com/articles/20/06/08/what-to-expect-at-wwdc-2020--%20--%20and-what-not-to">Worldwide Developers Conference</a> on June 22, with the first of the ARM-based Macs due to potentially debut in 2021.</p></div><div class="col-sm-12"><p>That may come as a surprise to some casual Apple fans. For astute watchers of the company's moves, the signs of another major architecture transition have long been written on the wall.</p></div><div class="col-sm-12"><h2>Laying the groundwork for ARM Macs</h2></div><div class="col-sm-12"><div class="align-center"><img src="https://photos5.appleinsider.com/gallery/36149-67036-arm-mac-chip-xl.jpg" alt="Apple is already an ARM chipmaking expert, with A-series chips powering the company's iPhones, iPads and Apple TVs." class="img-responsive article-image" loading="lazy"></div><div class="col-sm-12"><span class="carousel-caption">Apple is already an ARM chipmaking expert, with A-series chips powering the company's iPhones, iPads and Apple TVs.</span></div></div><div class="col-sm-12"><p>Some of Apple's "tells" of a major architecture switch, such as Project Catalyst or the dropping of 32-bit support, have been more obviously apparent than others. </p></div><div class="col-sm-12"><p>When you look at the history of the Mac from about 2014 to 2020, it becomes clear that Apple has been taking subtle but sure steps creating a more ARM-friendly Mac ecosystem, and paving the way for an <a href="https://appleinsider.com/inside/arm-mac">ARM Mac</a> in general.</p></div><div class="col-sm-12"><p>Here's how Apple has laid the groundwork for ARM Macs for longer than a decade.</p></div><div class="col-sm-12"><h3>Xcode</h3></div><div class="col-sm-12"><p>Rumors of an ARM Mac are fairly recent, at least compared to the history of the Mac itself. But way back in 2003, Apple made what is really the first publicly visible step toward an ARM Mac: releasing <a href="https://appleinsider.com/inside/xcode">Xcode</a>.</p></div><div class="col-sm-12"><p>The Mac-based integrated development environment changed completely overhauled how developers created apps and programs for Apple platforms and products. Before the release of the integrated development environment, there was a slew of different tools for development and programming. </p></div><div class="col-sm-12"><p>While Apple may not have specifically had an ARM Mac in mind when it released Xcode, the unified IDE was needed for the iPhone, and was still the first initial step toward such a device. Without a centralized development environment for macOS, the current transition &mdash;  and the previous shift to Intel &mdash;  just wouldn't be possible.</p></div><div class="col-sm-12"><p>Xcode is also obviously built for the x86 architecture, but there are some <a href="https://appleinsider.com/articles/20/04/29/why-apple-may-bring-xcode-to-the-ipad-and-what-it-has-to-do">tentative signs</a> that Apple may bring the IDE to <a href="https://appleinsider.com/articles/20/04/20/xcode-may-be-coming-to-the-iphone-and-ipad-very-soon">ARM-based chips by way of an iPad app</a>.</p></div><div class="col-sm-12"><h3>OpenGL and Metal</h3></div><div class="col-sm-12"><p>Apple has been tightening up its signature blend of hardware, software and OS integration. The introduction of Metal on iOS in 2014 &mdash;  and <a href="https://appleinsider.com/articles/18/06/28/why-macos-mojave-requires-metal--%20--%20and-deprecates-opengl">ultimate deprecation</a> of OpenGL in 2018 &mdash;  introduced a new layer of independence for Apple developers. </p></div><div class="col-sm-12"><p>Compared to the previous graphics technology, Apple says Metal allows a CPU and GPU to "work together more effectively." By using Metal, both macOS and iOS developers could code to this specific API and allow their apps to function regardless of what GPU is present. For Apple-designed hardware like ARM chips, it's going to be integral, especially if Apple GPUs are on the distant horizon as well.</p></div><div class="col-sm-12"><p>That switch from the previous OpenGL technology began a broader Apple push toward interoperability for apps and developer platforms. Along with other developments on this list, the introduction of Metal played a role in streamlining and simplifying the larger Apple ecosystem.</p></div><div class="col-sm-12"><p>Although not a heralding of ARM-based Mac devices, some in the Apple development community <a href="https://twitter.com/stroughtonsmith/status/1270322312173232129">suggest</a> that deprecated technologies like OpenGL are going to be completely removed during the architecture switch. Based on the fact that OpenGL dependencies are already integrated using Metal, it looks like Apple has been planning for this since the technology was deprecated.</p></div><div class="col-sm-12"><h3>Swift</h3></div><div class="col-sm-12"><p>Apple's open-source <a href="https://appleinsider.com/inside/swift">Swift</a> programming language came the exact same year, and further added opportunities for Apple &mdash;  and Apple developers &mdash;  to bring its disparate products together. </p></div><div class="col-sm-12"><p>The initial goal of Swift was to create a language that was fast, intuitive and safer to use than what was available at the time. Importantly, it was also developed from the ground up with Apple's own products in mind. As mentioned earlier, Swift is part of a larger strategy of optimizing apps and code for different devices on iOS, and eventually, iPadOS. There's no doubt Apple will apply the lessons it learned from those platforms to ARM Macs.</p></div><div class="col-sm-12"><p>Some Swift-based toolkits, like SwiftUI, could also play a larger role in the transition to ARM-based Macs. <a href="https://appleinsider.com/articles/19/06/19/wwdc19-swiftui-was-the-brightest-star-in-a-galaxy-of-new-ideas">SwiftUI</a> is an easy way for app developers to build user interfaces for products across Apple's lineup</p></div><div class="col-sm-12"><p>More than that, there's the looming possibility of Apple dropping support for apps not written in Swift entirely, though developers like Gus Mueller <a href="https://shapeof.com/archives/2020/6/educated_guesses_about_a_mac_transition_to_arm.html">suggest</a> that it won't happen at first. If or whether it does, it'll be because Apple believes that having a single coding language for apps across iOS, macOS and Apple's other platforms is going to make optimization and performance better across the board.</p></div><div class="col-sm-12"><h3>System Integrity Protection</h3></div><div class="col-sm-12"><p>In 2015, Apple also introduced a new system feature called System Integrity Protection (SIP) to the kernel of <a href="https://appleinsider.com/inside/os-x-el-capitan">OS X El Capitan</a>. At the time, some <a href="https://arstechnica.com/gadgets/2015/09/os-x-10-11-el-capitan-the-ars-technica-review/8/#h1">theorized</a> that it could be an initial effort for Apple to bring macOS security policies closer to those of iOS. </p></div><div class="col-sm-12"><p>While System Integrity Protection did bolster security, it did do away with some of the UNIX-like system functions that macOS had for years. And by doing so, it took macOS a step toward its other operating systems  &mdash;  which are, importantly, already designed for ARM.</p></div><div class="col-sm-12"><p>That's important because many of the <a href="https://appleinsider.com/articles/19/05/14/zombieload-vulnerability-in-intel-processors-puts-data-in-danger-on-mac">significant</a> <a href="https://appleinsider.com/articles/18/05/04/more-spectre-style-chip-flaws-discovered-in-intel-processors">security</a> <a href="https://appleinsider.com/articles/19/03/05/new-spoiler-vulnerability-in-all-intel-core-processors-exposed-by-researchers">flaws</a> we've seen over the past few years have been chip-level vulnerabilities in Intel's silicon. There's a high possibility that Apple will market the switch to ARM as a security upgrade, along with the many other benefits. </p></div><div class="col-sm-12"><h3>Apple T-series chips and Secure Boot</h3></div><div class="col-sm-12"><p>Long before serious talk about Apple ditching Intel for ARM, the Cupertino tech giant put ARM-based silicon into its Macs. Apple's introduction to ARM in the Mac was the T1 coprocessor chip in the 2016 MacBook Pro with Touch Bar.</p></div><div class="col-sm-12"><p>In addition to powering the touchscreen OLED Touch Bar, the T1 also enabled the Touch ID sensor and drove the System Management Controller. Based on a similar core to ARM chips like the Apple Watch's S1, the T1 allows the Touch Bar to <a href="https://appleinsider.com/articles/16/10/28/examined-the-new-macbook-pro-touch-bar-and-apples-t1-authentication-chip">operate relatively independently</a> of the actual system.</p></div><div class="col-sm-12"><p>A year later, in 2017, Apple debuted the second generation of its T-series chips in the iMac Pro. Like A-series chips, the T2 enabled a suite of security functions for macOS, including a secure enclave and on-the-fly encryption. It also enabled always-on "Hey Siri," acts as a "gatekeeper" for a Mac's microphone and FaceTime camera, and could speed up certain <a href="https://appleinsider.com/articles/19/04/09/apples-t2-chip-makes-a-giant-difference-in-video-encoding-for-most-users">video-based encoding workflows</a>.</p></div><div class="col-sm-12"><p>The T2 chip is a significant win for <a href="https://appleinsider.com/articles/19/12/19/apples-platform-security-guide-details-how-customer-data-is-protected">Apple platform security</a>, as well as other associated image processing features. </p></div><div class="col-sm-12"><p>From our vantage point, it also appears as a sort of "test run" for integrating ARM technology in X86 Macs. The T-series chips are purpose-built, customized chips specifically designed for Macs. With a switch to ARM-based CPUs, there are opportunities for even further integration, especially since Apple could ditch the T2 chip and bake its features directly into an ARM system-on-chip (SoC).</p></div><div class="col-sm-12"><h3>Death of 32-bit apps</h3></div><div class="col-sm-12"><p>One of the more major changes that paved the way for ARM Macs was the death of 32-bit apps. In <a href="https://appleinsider.com/articles/19/06/03/apple-reveals-which-macs-will-run-macos-catalina">macOS Catalina</a>, officially dropped support for 32-bit apps. </p></div><div class="col-sm-12"><p>That capped out a transition nearly a decade in the making with the release of 64-bit OS X Snow Leopard in 2009. It's especially important because it spelled the end of all the <a href="https://appleinsider.com/articles/18/06/05/mojave-is-apples-last-version-of-macos-to-support-32-bit-apps">legacy 32-bit code</a> that Macs have been running for years.</p></div><div class="col-sm-12"><p>Without all of that legacy code, a Mac could, in theory, optimized to run on 64-bit ARM processors. For a transition to ARM-based Macs, that's going to be an important point for making them perform at their best.</p></div><div class="col-sm-12"><p>For context, the A-series chips in iPhones and iPads are 64-bit and ARM-based. Similarly, Apple technologies like Metal only work on 64-bit architecture. In other words, the implementation of 64-bit technology implemented across Apple's lineup cleans up the company's stable of operating systems for further tinkering and new features.</p></div><div class="col-sm-12"><h3>Catalyst</h3></div><div class="col-sm-12"><p>Then there was Catalyst, one of the more apparent signs of integrating ARM support into the macOS ecosystem. Introduced at WWDC 2019, Catalyst is essentially a system designed to allow developers to more easily <a href="https://appleinsider.com/articles/19/10/24/apple-will-add-more-to-help-catalyst-to-support-mac-developers">port iOS and iPadOS apps to the Mac</a>. It didn't automatically spell the end of macOS-specific apps or Mac as a separate operating system, but it did lay a foundation for apps that could be optimized for an ARM environment.</p></div><div class="col-sm-12"><p>While initial reactions to Catalyst were <a href="https://appleinsider.com/articles/19/09/04/apples-catalyst-polarizes-developers-ahead-of-ios-13-catalina-launch">mixed</a>, the platform did introduce features that significantly lower the barrier to entry for iOS and Mac app integration by allowing developers to effortlessly compile code for the latter platform. Effortlessly as in ticking a box in Xcode.</p></div><div class="col-sm-12"><p>Apple could undoubtedly take the lessons it learned on iOS and apply them to macOS. The iOS App Store, for example, has long allowed consumers to download apps regardless of what specific code was needed to run on a specific device.  But, more importantly, <a href="https://appleinsider.com/articles/19/06/20/macos-catalina-beta-hints-apple-is-building-catalyst-versions-of-messages-and-shortcuts">Catalyst</a> makes it easy for developers to create apps that can work on both ARM and x86 architecture. </p></div><div class="col-sm-12"><p>That's something that could smooth the transition for developers and consumers alike, since it'll make porting apps to an ARM-optimized version of macOS as easy as porting one from iPad to Mac. This will save developers time and hassle, particularly since the overall transition to ARM-based Macs isn't going to be a short one.</p></div><div class="col-sm-12"><p>Apple isn't going to drop non-Catalyst apps out of the gate. But having Catalyst as an option for developers to create ARM-friendly content is going to make the transition a bit easier to handle.</p></div><div class="col-sm-12"><h2>The actual start of the "transition" to ARM Macs</h2></div><div class="col-sm-12"><div class="align-center"><img src="https://photos5.appleinsider.com/gallery/36149-67038-Mac-Catalyst-xl.jpg" alt="Catalyst, by allowing apps easier interoperability between ARM and x86 architecture, could make the transition easier on developers." class="img-responsive article-image" loading="lazy"></div><div class="col-sm-12"><span class="carousel-caption">Catalyst, by allowing apps easier interoperability between ARM and x86 architecture, could make the transition easier on developers.</span></div></div><div class="col-sm-12"><div class="align-center"><img src="https://photos5.appleinsider.com/gallery/36149-67038-Mac-Catalyst-xl.jpg" alt="" class="img-responsive article-image" loading="lazy"></div></div><div class="col-sm-12"><p>The 2018 <a href="https://appleinsider.com/inside/ipad-pro">iPad Pro</a> really clarified something about how Apple views its computing products. As the company noted at its iPad keynote that year, the iPad Pro overhaul was speedier than up to 92% of competing laptops of that time.</p></div><div class="col-sm-12"><p>That didn't necessarily pertain to macOS in any way, but it made it clear that Apple's A-series chipsets were built for power. While Apple maintained that it won't merge Mac and iPad, it said nothing about making the former ecosystem more like the latter.</p></div><div class="col-sm-12"><p>For eagle-eyed technologists and enthusiasts, it also hinted at the potential of Apple's first-party ARM silicon. </p></div><div class="col-sm-12 ad"><div class="primis-ad-wrap"></div></div><div class="col-sm-12"><p>Consider the fact that A-series chips can <a href="https://appleinsider.com/articles/19/10/22/editorial-why-the-apple-a13-bionic-blows-past-qualcomm-snapdragon-855-plus">outperform Intel ones in many single-core benchmarks</a>. Those A-series chips are installed on devices without thermal cooling &mdash;  one barrier to workstation-like performance from ARM chips.</p></div><div class="col-sm-12"><p>A switch to ARM would be the third major architecture transition in Apple's lifetime, after moving from Motorola 68000 to PowerPC, and <a href="https://iphone.appleinsider.com/articles/05/06/06/wall_street_weighs_in_on_apple_intel_rumors">from PowerPC to Intel</a> x86 in 2005. Just like those past architecture transitions, Apple has a clear goal and path in mind for the switch to ARM. It's going to make Mac devices <em>better</em>, whether through enhanced performance or better battery life.</p></div><div class="col-sm-12"><p>Amid persistent rumors of an impending ARM-based announcement, Apple will likely make the public aware of what it's been doing behind the scenes for years.</p></div><div class="col-sm-12"><h2>What Apple still needs to do</h2></div><div class="col-sm-12"><div class="align-center"><img src="https://photos5.appleinsider.com/gallery/36149-67067-49923977557_59e56f62e7_k-xl.jpg" alt="Apple may give developers a first taste of ARM with " development tool kits which were desktop intel machines. class="img-responsive article-image" loading="lazy"></div><div class="col-sm-12"><span class="carousel-caption">Apple may give developers a first taste of ARM with "development tool kits," which were desktop Intel machines.</span></div></div><div class="col-sm-12"><p>The transition to ARM will be as seamless as possible, but it won't be without pain for some. While Apple has made a series of preparations, it's <a href="https://appleinsider.com/articles/20/03/17/how-apples-move-to-an-arm-mac-is-going-to-be-a-bumpy-road-for-some">still going to be a mammoth task</a> for both the company, its independent developers, and its customers.</p></div><div class="col-sm-12"><p>Apple took a bit less than two years to move all of its Macs over to Intel-based chips. It took until August 2009 for OS X Snow Leopard to drop support for PowerPC architecture. Previously released PowerPC-based hardware was officially declared "obsolete" in 2013 &mdash;  seven years after Apple discontinued them.</p></div><div class="col-sm-12"><p>It's undoubtedly going to be a bumpy road for some, but Apple's previous chip architecture transitions could hint at what's coming.</p></div><div class="col-sm-12 embed"><div class="align-center"><div class="embed-responsive embed-responsive-16by9 video-holder"><iframe src="https://www.youtube.com/embed/ghdTqnYnFyg" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen class="embed-responsive-item"></iframe></div></div></div><div class="col-sm-12"><p>Consider Apple's <a href="https://appleinsider.com/articles/05/06/23/inside_apples_intel_based_dev_transition_kit_photos">Development Transition Kits</a>, which were $999 computers based on Intel hardware "rented" out to developers. There's a good chance that, for a switch as massive as Intel-to-ARM, Apple is going to do something similar. So developers with the means will be able to get their apps ARM-compatible well before consumers get their hands on the hardware.</p></div><div class="col-sm-12"><p>Apple apparently believes this shift to be important, and not just because of Intel's recent hiccups. With much more minute control over the entire hardware and software stack of its devices, costs will be reduced and potential integration and optimization could be supercharged.</p></div><div class="col-sm-12"><p>The switch to ARM could also further bolster Apple's status as a chipmaking superpower. Later, when the dust settles, consumers will be <a href="https://appleinsider.com/articles/20/02/25/why-apple-will-move-macs-to-arm-and-what-consumers-get">getting a lot more</a>, too.</p></div><div class="col-sm-12"><p>Apple's Mac transition to ARM has been years in the making. While it may be too early to tell how it pans out, it looks likely that it'll be worth the growing pains for everyone involved.</p></div></div>

        </div>
        <hr class="hidden-lg hidden-xs">
                  <aside class="col-sm-12 inline-disclaimer"> 
    <p>
        <em>AppleInsider has affiliate partnerships and may earn commission on products purchased through affiliate links. 
        These partnerships do not influence our editorial content.</em>
    </p>
</aside>
              </div>
    </article>
  </main>

  <div class="col-sm-8">&nbsp;</div>
  <div class="col-sm-4 comment-count hidden-lg">
          <span class="badge">
        <a href="https://forums.appleinsider.com/discussion/216207">
          11 Comments
          <span class="carrot"><img loading="lazy" src="https://photos5.appleinsider.com/v10/images/commentcarrot.png" alt="comment count carrot"></span>
        </a>
      </span>
      </div>
</div>
<!--  ************************** Left Side Upper half END ************************** -->

<!-- ************************** right side upper ads  ************************** -->
  <div class="col-lg-3 col-xs-12">
    <!-- advertisement goes here -->
    <div class="visible-lg" style="padding-top:10px;">&nbsp;</div>

    <div class="hidden-xs">
      <hr class="hidden-md">
      <hr class="visible-md">
<h2 class="uc">Related Articles</h2>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/12/arm-mac-transition-imac-redesign-and-our-wwdc-wishlist-on-the-appleinsider-podcast"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36179-67074-wwdc2020-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/12/arm-mac-transition-imac-redesign-and-our-wwdc-wishlist-on-the-appleinsider-podcast">ARM Mac transition, iMac redesign, and our WWDC wishlist on the AppleInsider podcast</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/08/what-to-expect-at-wwdc-2020----and-what-not-to"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36124-66928-000-lead-WWDC-2020-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/08/what-to-expect-at-wwdc-2020----and-what-not-to">What to expect at WWDC 2020 &amp;mdash; and what not to</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/11/apple-announces-wwdc-keynote-timeline-week-long-conference-schedule"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36175-67063-Apple_details-for-WWDC2020_06022020_bigjpglarge_2x-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/11/apple-announces-wwdc-keynote-timeline-week-long-conference-schedule">Apple announces WWDC keynote timeline, week-long conference schedule</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/11/how-to-manage-notifications-in-macos"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36153-67017-header-m.png" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/11/how-to-manage-notifications-in-macos">How to manage notifications in macOS</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/10/apple-was-cautious-when-it-shifted-to-intel-and-an-arm-mac-migration-will-be-no-different"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36139-67003-000-lead-Intel-move-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/10/apple-was-cautious-when-it-shifted-to-intel-and-an-arm-mac-migration-will-be-no-different">Apple was cautious when it shifted to Intel, and an ARM Mac migration will be no different</a></h2>
        </div>
    </div>
</article>
<hr>
    </div>
    
    <hr class="hidden-lg hidden-md hidden-sm">
<div class="boxes ad">
    <div class="box">
        <div class="ad-mrec" style="width: 300px; max-width: 300px; overflow: hidden; margin: 0 auto">
            <div id="div-gpt-ad-1587659960977-0" class="hidden-xs">
                <script>
                    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1587659960977-0'); });
                </script>
            </div>
            <div id="div-gpt-ad-1586972924313-0" class="visible-xs">
                <script>
                    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1586972924313-0'); });
                </script>
            </div>            
        </div>
    </div>
</div>
    <hr>

    <div class="hidden-xs">
      <article class="feat-deal2">
  <div class="row">
    <div class="col-xs-3 avatar-link">
      <img class="img-responsive" src="https://photos5.appleinsider.com/price_guide/featured-deal/apple-airpods-pro.png" alt="Apple AirPods Pro Deal">
    </div>
    <div class="col-xs-9"><span class="Stockdown">Save up to $30</span> <br><a href="https://deals.appleinsider.com/deal/20/04/21/15-to-40-off-airpods-2">Lowest prices on Apple AirPods</a></div>
  </div>
</article>
<p></p>
<p></p>
<article class="feat-deal2">
  <div class="row">
    <div class="col-xs-3 avatar-link">
      <img class="img-responsive" src="https://photos5.appleinsider.com/price_guide/featured-deal/2020-ipad-pro.png" alt="New 2020 iPad Pro discounts">
    </div>
    <div class="col-xs-9"><span class="Stockdown">Save up to $70</span> <br><a href="https://deals.appleinsider.com/deal/20/04/10/new-2020-ipad-pro-models-are-already-up-to-70-off-deals-on-applecare">2020 iPad Pros are on sale</a></div>
  </div>
</article>
<p></p>
<p></p>
<article class="feat-deal2">
  <div class="row">
    <div class="col-xs-3 avatar-link">
      <img class="img-responsive" src="https://photos5.appleinsider.com/price_guide/featured-deal/macbook-air-2020-gold.png" alt="Apple MacBook Air deals">
    </div>
    <div class="col-xs-9"><span class="Stockdown">Save $50</span> <br><a href="https://deals.appleinsider.com/deal/20/04/25/every-2020-macbook-air-is-eligible-for-this-coupon-discount">Save on all upgraded MacBook Airs</a></div>
  </div>
</article>
    </div>
    <div class="hidden-xs">
      <hr>
      <div class="boxes ad">
    <div class="box">
        <div id="div-gpt-ad-1588086356674-0" class="ad-mred" style='width: 300px; height: 250px; margin: 0 auto;'>
            <script>
                googletag.cmd.push(function() { googletag.display('div-gpt-ad-1588086356674-0'); });
            </script>
        </div>
    </div>
</div>
<hr class="visible-xs">    </div>
    <!-- <hr class="visible-md">
<h2 class="uc">
    
            Latest tips
    </h2>

    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/12/how-to-manage-notifications-in-ios-13-and-ipados-13"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36154-67039-jrsfrt-m.png" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/12/how-to-manage-notifications-in-ios-13-and-ipados-13">How to manage notifications in iOS 13 and iPadOS 13</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/11/how-to-manage-notifications-in-macos"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36153-67017-header-m.png" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/11/how-to-manage-notifications-in-macos">How to manage notifications in macOS</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/10/how-to-factory-reset-an-apple-watch"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36151-66987-header-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/10/how-to-factory-reset-an-apple-watch">How to factory reset an Apple Watch</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/08/how-to-play-apple-music-on-your-echo-dot"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36130-66944-echodot-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/08/how-to-play-apple-music-on-your-echo-dot">How to play Apple Music on your Echo Dot</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/07/how-to-record-a-video-of-your-iphone-11s-screen"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36101-66847-000-lead-Screen-Recording-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/07/how-to-record-a-video-of-your-iphone-11s-screen">How to record a video of the iPhone 11 screen</a></h2>
        </div>
    </div>
</article>
<hr>
 -->
    <div class="hidden-xs">
              <hr class="visible-md">
<h2 class="uc">
                
            Latest comparisons
    </h2>

    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/08/compared-razer-blade-pro-17-versus-apple-16-inch-macbook-pro"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36054-66909-razer-blade-pro-1-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/08/compared-razer-blade-pro-17-versus-apple-16-inch-macbook-pro">Compared: Razer Blade Pro 17 versus Apple 16-inch MacBook Pro</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/02/here-are-our-favorite-cases-for-iphone-se-2020"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/35979-66700-iPhoen-Se-2020-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/02/here-are-our-favorite-cases-for-iphone-se-2020">Here are our favorite cases for iPhone SE (2020)</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/02/compared-razer-blade-stealth-13-versus-apples-13-inch-macbook-pro"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36027-66620-razer-blade-stealth-13-1-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/02/compared-razer-blade-stealth-13-versus-apples-13-inch-macbook-pro">Compared: Razer Blade Stealth 13 versus Apple&#039;s 13-inch MacBook Pro</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/01/intels-xeon-nuc-9-pro-kit-is-what-we-want-to-see-in-a-mac-pro-mini"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/35365-66615-NUC-and-mac-mini-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/01/intels-xeon-nuc-9-pro-kit-is-what-we-want-to-see-in-a-mac-pro-mini">Intel&#039;s Xeon NUC 9 Pro kit is what we want to see in a &#039;Mac Pro mini&#039;</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/05/27/compared-dell-s-xps-15-and-xps-17-versus-apples-16-inch-macbook-pro"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/35841-66428-dell-xps-15-xps-17-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/05/27/compared-dell-s-xps-15-and-xps-17-versus-apples-16-inch-macbook-pro">Compared: Dell XPS 15 and XPS 17 versus Apple&#039;s 16-inch MacBook Pro</a></h2>
        </div>
    </div>
</article>
<hr>
          </div>
  </div>
  <!-- ************************** right side upper ads END **************************-->
      <aside>
    <div class="container hidden-xs">
        <div class="row">
            <div class="col-lg-9 comment-paddingFix">
                <h2 class="comment-section-head">Comments (11)</h2>
                                                            <div class="col-sm-12 forum-comment">
    <div class="row">
        <h2><a href="https://forums.appleinsider.com/profile/jharner"><img loading="lazy" class="user-avatar" src="https://vanillicon.com/v2/bb013e3dac738448ac1e3e799620593c.svg" alt="jharner" alt="Forum user avatar" />jharner</a> Said: </h2>
        <p><p>The problem is that Macs are used extensively in STEM, including data science and statistics. These disciplines depend almost entirely on open source software that runs on UNIX/Linux. Further, increasingly applications are dockerized meaning the development switches to some extent to Docker and Kubernetes. Applications like R are run by millions and of course there is Python. Docker requires root access. Will these environments still be available on ARM Macs. If not, Apple may lose perhaps 10s of millions of potential users including faculty and students at universities. Does anyone have any insight into what could be a disaster for Macs in higher education and industry if these environments are lost?</p>
</p>
    </div>
    <hr>
</div>
               
                                                                                <div class="col-sm-12 forum-comment">
    <div class="row">
        <h2><a href="https://forums.appleinsider.com/profile/Rayz2016"><img loading="lazy" class="user-avatar" src="https://vanillicon.com/v2/e063d07f137129347f6901218622a26e.svg" alt="Rayz2016" alt="Forum user avatar" />Rayz2016</a> Said: </h2>
        <p><blockquote class="Quote">
  <div class="QuoteAuthor"><a href="https://forums.appleinsider.com/profile/244444/jharner" rel="nofollow">jharner</a> said:</div>
  <div class="QuoteText">The problem is that Macs are used extensively in STEM, including data science and statistics. These disciplines depend almost entirely on open source software that runs on UNIX/Linux. Further, increasingly applications are dockerized meaning the development switches to some extent to Docker and Kubernetes. Applications like R are run by millions and of course there is Python. Docker requires root access. Will these environments still be available on ARM Macs. If not, Apple may lose perhaps 10s of millions of potential users including faculty and students at universities. Does anyone have any insight into what could be a disaster for Macs in higher education and industry if these environments are lost?</div>
<p>
I think that running an accessible Unix subsystem (however they plan to make it work) will be one of the main differences between iOS and MacOS going forward. These days I see more developers running Macs than Windows, so I&rsquo;d be surprised if Apple abandoned that.&nbsp;</p></blockquote>
</p>
    </div>
    <hr>
</div>
               
                                                                                <div class="col-sm-12 forum-comment">
    <div class="row">
        <h2><a href="https://forums.appleinsider.com/profile/jdb8167"><img loading="lazy" class="user-avatar" src="https://vanillicon.com/v2/1b400160baa6ec775abf2106e5e8341c.svg" alt="jdb8167" alt="Forum user avatar" />jdb8167</a> Said: </h2>
        <p><blockquote class="Quote">
  <div><a rel="nofollow" target="_blank">jharner</a> said:</div>
  <div>The problem is that Macs are used extensively in STEM, including data science and statistics. These disciplines depend almost entirely on open source software that runs on UNIX/Linux. Further, increasingly applications are dockerized meaning the development switches to some extent to Docker and Kubernetes. Applications like R are run by millions and of course there is Python. Docker requires root access. Will these environments still be available on ARM Macs. If not, Apple may lose perhaps 10s of millions of potential users including faculty and students at universities. Does anyone have any insight into what could be a disaster for Macs in higher education and industry if these environments are lost?</div>
<p>
Since everything is open source, it doesn't seem like much of a risk. I'm just going to assume that Apple is porting (probably has always ported) all of macOS to ARM. This would cause problems for anyone assuming that Boot Camp runs Windows or that Parallels, VMWare, or VirtualBox will allow x86_64 compiled software to run in a virtual machine but anyone just running open source tools and applications will just have to recompile for ARM. For something like Brew, this is likely to be automatic. <br><br>Of course there will be bugs, but there are always bugs. Open source means that the people who need the code to work will just fix it and update the repositories. A few months of work and everything probably will be back to normal. No one who relies on a particular open source app should update to an ARM based Mac until their requirements are ported. Same as always.<br><br>For some reason (probably a general lack of knowledge about computer architecture) many people seem to assume that because the new Mac architecture will be based on ARM, that it will run some derivative of iOS. This is not necessary. Apple has all the source code to macOS and can simply build the entire OS and all support libraries for the ARM architecture. Again, there will be bugs and extensive testing is required but that is Apple's job. They won't release ARM macOS to the public until it meets their normal quality standards (no snark about Catalina).</p></blockquote>
</p>
    </div>
    <hr>
</div>
               
                                                                                <div class="col-sm-12 forum-comment">
    <div class="row">
        <h2><a href="https://forums.appleinsider.com/profile/tht"><img loading="lazy" class="user-avatar" src="https://vanillicon.com/v2/0a399498ef6fed0bcc7c1309c4ab03cd.svg" alt="tht" alt="Forum user avatar" />tht</a> Said: </h2>
        <p><blockquote class="Quote">
  <div class="QuoteAuthor"><a href="https://forums.appleinsider.com/profile/244444/jharner" rel="nofollow">jharner</a> said:</div>
  <div class="QuoteText">The problem is that Macs are used extensively in STEM, including data science and statistics. These disciplines depend almost entirely on open source software that runs on UNIX/Linux. Further, increasingly applications are dockerized meaning the development switches to some extent to Docker and Kubernetes. Applications like R are run by millions and of course there is Python. Docker requires root access. Will these environments still be available on ARM Macs. If not, Apple may lose perhaps 10s of millions of potential users including faculty and students at universities. Does anyone have any insight into what could be a disaster for Macs in higher education and industry if these environments are lost?</div>
<p>
I think it will be a straight port of macOS 10.16, whatever the current version of macOS it is. So, the Unix subsystem on macOS/ARM will be exposed to the use just like it is today.&nbsp;I'm tempted to believe the Apple will eventually ship a VM running DarwinOS for iPadOS. Not sure how it integrate with iPadOS, but it's going to be a separate install of DarwinOS running in a VM.<br><br>There really isn't much reason to drive macOS to become iPadOS like. There will be default configurations to make macOS safer for new users, but all that can be switched off to exposed Unix, side loading, etc.</p></blockquote>
</p>
    </div>
    <hr>
</div>
               
                                                                                <div class="col-sm-12 forum-comment">
    <div class="row">
        <h2><a href="https://forums.appleinsider.com/profile/hexclock"><img loading="lazy" class="user-avatar" src="https://vanillicon.com/v2/2b8d52124e2e31d10574d5225c1f8a0f.svg" alt="hexclock" alt="Forum user avatar" />hexclock</a> Said: </h2>
        <p><blockquote class="Quote">
  <div class="QuoteAuthor"><a href="https://forums.appleinsider.com/profile/51615/jdb8167" rel="nofollow">jdb8167</a> said:</div>
  <div class="QuoteText"><blockquote class="Quote">
  <div><a rel="nofollow" target="_blank">jharner</a> said:</div>
  <div>The problem is that Macs are used extensively in STEM, including data science and statistics. These disciplines depend almost entirely on open source software that runs on UNIX/Linux. Further, increasingly applications are dockerized meaning the development switches to some extent to Docker and Kubernetes. Applications like R are run by millions and of course there is Python. Docker requires root access. Will these environments still be available on ARM Macs. If not, Apple may lose perhaps 10s of millions of potential users including faculty and students at universities. Does anyone have any insight into what could be a disaster for Macs in higher education and industry if these environments are lost?</div>
</blockquote>.<br><br>For some reason (probably a general lack of knowledge about computer architecture) many people seem to assume that because the new Mac architecture will be based on ARM, that it will run some derivative of iOS. This is not necessary. Apple has all the source code to macOS and can simply build the entire OS and all support libraries for the ARM architecture.</div>
<p>
OS X was always designed to be platform independent, and iOS is just a subset of OS X, or at least it was. I know they have both evolved a great deal over the years, but to what extent I don&rsquo;t know. Has iOS diverged so much from MacOS that it could supplant it?</p></blockquote>
</p>
    </div>
    <hr>
</div>
               
                                                                                                                                                                                                                                                                            <div class="col-lg-12" style="text-align:right;">
                    <a class="comments-read-more-link" href="https://forums.appleinsider.com/discussion/216207#first-reply" style="padding: 5px;">Read More on the forums...</a>
                </div>
                <div id="vanilla-comments"></div>
                    <script>
                        var vanilla_forum_url = 'https://forums.appleinsider.com/';
                        var vanilla_identifier = 'vanilla-comments';
                        var vanilla_discussion_id = '191948';

                        /*** DON'T EDIT BELOW THIS LINE ***/
                        (function() {
                            var vanilla = document.createElement('script');
                            vanilla.type = 'text/javascript';
                            var timestamp = new Date().getTime();
                            vanilla.src = vanilla_forum_url + '/js/embed.js';
                            (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(vanilla); 
                        })();
                    </script>
                    <noscript>Please enable JavaScript to view comments</noscript>
                </div>
                </div> <!-- I don't know why we need to close a div here, assume it's related to the vanilla embed -->
            </div>
        </div>
    </div>
</aside>
    <!-- Dark mode support needs to be added to embed inside forums css to color correctly -->
  </div>

</div> <!-- /content -->

  <div id="topic-nav" class="hidden-xs fluid-container">
  <div class="container text-center">
  <nav class="nav">
      <ul>
        <li><a href="https://appleinsider.com/inside/iphone-12">iPhone 12</a></li>
        <li><a href="https://appleinsider.com/inside/ios-14">iOS 14</a></li>
        <li><a href="https://appleinsider.com/inside/iphone-se">iPhone SE</a></li>
        <li><a href="https://appleinsider.com/inside/mac-pro">Mac Pro</a></li>
        <li><a href="https://appleinsider.com/inside/airtags">AirTags</a></li>
        <li><a href="https://appleinsider.com/inside/14-inch-macbook-pro">14" MacBook Pro</a></li>
        <li class="hidden-sm"><a href="https://appleinsider.com/inside/airpods-pro">AirPods Pro</a></li>
        <li class="hidden-sm"><a href="https://appleinsider.com/inside/arm-mac">ARM MacBooks</a></li>
        <li class="hidden-md visible-xl"><a href="https://appleinsider.com/inside/apple-watch-series-6">Apple Watch Series 6</a></li>
        <li class="hidden-sm hidden-md visible-xl"><a href="https://appleinsider.com/inside/apple-glass">Apple Glass</a>
      </ul>
    </nav>
  </div>
</div>
  <div class="container">
      <div class="row">
        <h2 class="block-header uc">Latest News</h2>
        <div class="col-lg-9">
                      <article class="main-art river">
  <div class="row">
    <div class="col-sm-4 col-xs-5">
      <a href="https://appleinsider.com/articles/20/06/12/ten-years-of-apple-technology-shifts-made-the-arm-mac-possible"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/apps/ipad/images/articles/53214.jpg" alt="article thumbnail"></a>
      <img loading="lazy" class="avatar img-circle hidden-xs" src="https://photos5.appleinsider.com/gallery/malcolm+owen.jpg" alt="author image">
    </div>
    <div class="col-sm-8 col-xs-7">
      <div class="visible-xs">
        <p><a href="https://appleinsider.com/articles/20/06/13/facebook-tests-face-id-authentication-for-ios-messenger-app">Facebook tests Face ID authentication for iOS Messenger app</a></p>
        <span class="avatar-link">1 hour ago </span>
      </div>
      <div class="row hidden-xs">
        <div class="col-sm-12">
          <h2 class="blueHover"><a href="https://appleinsider.com/articles/20/06/13/facebook-tests-face-id-authentication-for-ios-messenger-app">Facebook tests Face ID authentication for iOS Messenger app</a></h2>
          Facebook is quietly testing out a feature for its Messenger app to authenticate users via Face ID or Touch ID, a feature that may help keep accounts secure and private, even if the user lends their iPhone to someone else. 
        </div>
        <!--
        <div class="col-sm-3">
          <span class="hidden-xs fauxH3">ios</span>
        </div> -->
                <div class="col-sm-10 avatar-link river-author-byline">
          By <a href="https://appleinsider.com/editor/Malcolm+Owen">Malcolm Owen</a>  |  1 hour ago
        </div>
        <div class="col-sm-2 river-comments">
                    <a href="https://forums.appleinsider.com/discussion/216216"><span class="badge">2<span class="carrot"><img loading="lazy" src="https://photos5.appleinsider.com/v10/images/commentcarrot.png" alt="comment count carrot"></span></span></a>
                  </div>
      </div>
  </div>
  </div>
  <hr>
</article>
                      <article class="main-art river">
  <div class="row">
    <div class="col-sm-4 col-xs-5">
      <a href="https://appleinsider.com/articles/20/06/12/ten-years-of-apple-technology-shifts-made-the-arm-mac-possible"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/apps/ipad/images/articles/53213.jpg" alt="article thumbnail"></a>
      <img loading="lazy" class="avatar img-circle hidden-xs" src="https://photos5.appleinsider.com/gallery/mikey+campbell.jpg" alt="author image">
    </div>
    <div class="col-sm-8 col-xs-7">
      <div class="visible-xs">
        <p><a href="https://appleinsider.com/articles/20/06/13/apple-sued-for-allowing-apps-with-loot-boxes-onto-app-store">Apple sued for allowing loot boxes in App Store</a></p>
        <span class="avatar-link">12 hours ago </span>
      </div>
      <div class="row hidden-xs">
        <div class="col-sm-12">
          <h2 class="blueHover"><a href="https://appleinsider.com/articles/20/06/13/apple-sued-for-allowing-apps-with-loot-boxes-onto-app-store">Apple sued for allowing loot boxes in App Store</a></h2>
          Apple on Friday was hit with a proposed class action lawsuit targeting loot boxes in games and apps, a mechanism typically characterized by in-app purchases that present buyers with randomized digital rewards. 
        </div>
        <!--
        <div class="col-sm-3">
          <span class="hidden-xs fauxH3">general</span>
        </div> -->
                <div class="col-sm-10 avatar-link river-author-byline">
          By <a href="https://appleinsider.com/editor/Mikey+Campbell">Mikey Campbell</a>  |  12 hours ago
        </div>
        <div class="col-sm-2 river-comments">
                    <a href="https://forums.appleinsider.com/discussion/216214"><span class="badge">18<span class="carrot"><img loading="lazy" src="https://photos5.appleinsider.com/v10/images/commentcarrot.png" alt="comment count carrot"></span></span></a>
                  </div>
      </div>
  </div>
  </div>
  <hr>
</article>
                      <article class="main-art river">
  <div class="row">
    <div class="col-sm-4 col-xs-5">
      <a href="https://appleinsider.com/articles/20/06/12/ten-years-of-apple-technology-shifts-made-the-arm-mac-possible"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/apps/ipad/images/articles/53212.jpg" alt="article thumbnail"></a>
      <img loading="lazy" class="avatar img-circle hidden-xs" src="https://photos5.appleinsider.com/gallery/appleinsider+staff.jpg" alt="author image">
    </div>
    <div class="col-sm-8 col-xs-7">
      <div class="visible-xs">
        <p><a href="https://appleinsider.com/articles/20/06/12/apple-releases-teaser-for-apple-tv-original-little-voice">Apple releases teaser for Apple TV+ original &#039;Little Voice&#039;</a></p>
        <span class="avatar-link">14 hours ago </span>
      </div>
      <div class="row hidden-xs">
        <div class="col-sm-12">
          <h2 class="blueHover"><a href="https://appleinsider.com/articles/20/06/12/apple-releases-teaser-for-apple-tv-original-little-voice">Apple releases teaser for Apple TV+ original &#039;Little Voice&#039;</a></h2>
          Apple on Friday released a &quot;first look&quot; at Apple TV+ original series &quot;Little Voice,&quot; a J.J. Abrams-produced half-hour drama series set to debut in July.
        </div>
        <!--
        <div class="col-sm-3">
          <span class="hidden-xs fauxH3">apple tv</span>
        </div> -->
                <div class="col-sm-10 avatar-link river-author-byline">
          By <a href="https://appleinsider.com/editor/AppleInsider+Staff">AppleInsider Staff</a>  |  14 hours ago
        </div>
        <div class="col-sm-2 river-comments">
                    <a href="https://forums.appleinsider.com/discussion/216213"><span class="badge">0<span class="carrot"><img loading="lazy" src="https://photos5.appleinsider.com/v10/images/commentcarrot.png" alt="comment count carrot"></span></span></a>
                  </div>
      </div>
  </div>
  </div>
  <hr>
</article>
                      <article class="main-art river">
  <div class="row">
    <div class="col-sm-4 col-xs-5">
      <a href="https://appleinsider.com/articles/20/06/12/ten-years-of-apple-technology-shifts-made-the-arm-mac-possible"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/apps/ipad/images/articles/53211.jpg" alt="article thumbnail"></a>
      <img loading="lazy" class="avatar img-circle hidden-xs" src="https://photos5.appleinsider.com/gallery/mike+peterson.jpg" alt="author image">
    </div>
    <div class="col-sm-8 col-xs-7">
      <div class="visible-xs">
        <p><a href="https://appleinsider.com/articles/20/06/12/apple-seeking-to-invalidate-touchscreen-patents-used-against-it-in-lawsuit">Apple seeking to invalidate touchscreen patents used against it in lawsuit</a></p>
        <span class="avatar-link">15 hours ago </span>
      </div>
      <div class="row hidden-xs">
        <div class="col-sm-12">
          <h2 class="blueHover"><a href="https://appleinsider.com/articles/20/06/12/apple-seeking-to-invalidate-touchscreen-patents-used-against-it-in-lawsuit">Apple seeking to invalidate touchscreen patents used against it in lawsuit</a></h2>
          Apple has filed a lawsuit that seeks to invalidate intellectual property at the center of a patent infringement complaint lodged five years ago. 
        </div>
        <!--
        <div class="col-sm-3">
          <span class="hidden-xs fauxH3">iphone</span>
        </div> -->
                <div class="col-sm-10 avatar-link river-author-byline">
          By <a href="https://appleinsider.com/editor/Mike+Peterson">Mike Peterson</a>  |  15 hours ago
        </div>
        <div class="col-sm-2 river-comments">
                    <a href="https://forums.appleinsider.com/discussion/216212"><span class="badge">4<span class="carrot"><img loading="lazy" src="https://photos5.appleinsider.com/v10/images/commentcarrot.png" alt="comment count carrot"></span></span></a>
                  </div>
      </div>
  </div>
  </div>
  <hr>
</article>
                      <article class="main-art river">
  <div class="row">
    <div class="col-sm-4 col-xs-5">
      <a href="https://appleinsider.com/articles/20/06/12/ten-years-of-apple-technology-shifts-made-the-arm-mac-possible"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/apps/ipad/images/articles/53210.jpg" alt="article thumbnail"></a>
      <img loading="lazy" class="avatar img-circle hidden-xs" src="https://photos5.appleinsider.com/gallery/appleinsider+staff.jpg" alt="author image">
    </div>
    <div class="col-sm-8 col-xs-7">
      <div class="visible-xs">
        <p><a href="https://appleinsider.com/articles/20/06/12/apple-store-in-scotland-renamed-amid-worldwide-protests-for-racial-equality">Apple Store in Scotland renamed amid worldwide protests for racial equality</a></p>
        <span class="avatar-link">15 hours ago </span>
      </div>
      <div class="row hidden-xs">
        <div class="col-sm-12">
          <h2 class="blueHover"><a href="https://appleinsider.com/articles/20/06/12/apple-store-in-scotland-renamed-amid-worldwide-protests-for-racial-equality">Apple Store in Scotland renamed amid worldwide protests for racial equality</a></h2>
          As citizens in countries around the world call for a reckoning on racial justice and equality, Apple on Friday quietly renamed its Apple Buchanan Street store in Scotland to a title not associated with the prominent local slave owner. 
        </div>
        <!--
        <div class="col-sm-3">
          <span class="hidden-xs fauxH3">general</span>
        </div> -->
                <div class="col-sm-10 avatar-link river-author-byline">
          By <a href="https://appleinsider.com/editor/AppleInsider+Staff">AppleInsider Staff</a>  |  15 hours ago
        </div>
        <div class="col-sm-2 river-comments">
                    <a href="https://forums.appleinsider.com/discussion/216211"><span class="badge">10<span class="carrot"><img loading="lazy" src="https://photos5.appleinsider.com/v10/images/commentcarrot.png" alt="comment count carrot"></span></span></a>
                  </div>
      </div>
  </div>
  </div>
  <hr>
</article>
                      <article class="main-art river">
  <div class="row">
    <div class="col-sm-4 col-xs-5">
      <a href="https://appleinsider.com/articles/20/06/12/ten-years-of-apple-technology-shifts-made-the-arm-mac-possible"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/apps/ipad/images/articles/53209.jpg" alt="article thumbnail"></a>
      <img loading="lazy" class="avatar img-circle hidden-xs" src="https://photos5.appleinsider.com/gallery/mikey+campbell.jpg" alt="author image">
    </div>
    <div class="col-sm-8 col-xs-7">
      <div class="visible-xs">
        <p><a href="https://appleinsider.com/articles/20/06/12/us-house-committee-pushes-apple-ceo-tim-cook-to-testify-in-big-tech-probe">US House committee pushes Apple CEO Tim Cook to testify in big tech probe</a></p>
        <span class="avatar-link">15 hours ago </span>
      </div>
      <div class="row hidden-xs">
        <div class="col-sm-12">
          <h2 class="blueHover"><a href="https://appleinsider.com/articles/20/06/12/us-house-committee-pushes-apple-ceo-tim-cook-to-testify-in-big-tech-probe">US House committee pushes Apple CEO Tim Cook to testify in big tech probe</a></h2>
          The U.S. House Judiciary Committee this week sent letters to Apple, Alphabet, Amazon and Facebook asking whether their CEOs plan to participate in a series of antitrust hearings slated for July. 
        </div>
        <!--
        <div class="col-sm-3">
          <span class="hidden-xs fauxH3">general</span>
        </div> -->
                <div class="col-sm-10 avatar-link river-author-byline">
          By <a href="https://appleinsider.com/editor/Mikey+Campbell">Mikey Campbell</a>  |  15 hours ago
        </div>
        <div class="col-sm-2 river-comments">
                    <a href="https://forums.appleinsider.com/discussion/216210"><span class="badge">2<span class="carrot"><img loading="lazy" src="https://photos5.appleinsider.com/v10/images/commentcarrot.png" alt="comment count carrot"></span></span></a>
                  </div>
      </div>
  </div>
  </div>
  <hr>
</article>
                      <article class="main-art river">
  <div class="row">
    <div class="col-sm-4 col-xs-5">
      <a href="https://appleinsider.com/articles/20/06/12/ten-years-of-apple-technology-shifts-made-the-arm-mac-possible"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/apps/ipad/images/articles/53208.jpg" alt="article thumbnail"></a>
      <img loading="lazy" class="avatar img-circle hidden-xs" src="https://photos5.appleinsider.com/gallery/mike+peterson.jpg" alt="author image">
    </div>
    <div class="col-sm-8 col-xs-7">
      <div class="visible-xs">
        <p><a href="https://appleinsider.com/articles/20/06/12/apple-leaker-suggests-12-inch-macbook-refresh-could-be-first-arm-mac">Apple leaker suggests 12-inch MacBook refresh could be first ARM Mac</a></p>
        <span class="avatar-link">17 hours ago </span>
      </div>
      <div class="row hidden-xs">
        <div class="col-sm-12">
          <h2 class="blueHover"><a href="https://appleinsider.com/articles/20/06/12/apple-leaker-suggests-12-inch-macbook-refresh-could-be-first-arm-mac">Apple leaker suggests 12-inch MacBook refresh could be first ARM Mac</a></h2>
          Apple leaker Fudge, also known by their Twitter username choco_bit, has shared some thoughts on how, when and why Apple will switch its Macs to first-party ARM chips.
        </div>
        <!--
        <div class="col-sm-3">
          <span class="hidden-xs fauxH3">general</span>
        </div> -->
                <div class="col-sm-10 avatar-link river-author-byline">
          By <a href="https://appleinsider.com/editor/Mike+Peterson">Mike Peterson</a>  |  17 hours ago
        </div>
        <div class="col-sm-2 river-comments">
                    <a href="https://forums.appleinsider.com/discussion/216209"><span class="badge">14<span class="carrot"><img loading="lazy" src="https://photos5.appleinsider.com/v10/images/commentcarrot.png" alt="comment count carrot"></span></span></a>
                  </div>
      </div>
  </div>
  </div>
  <hr>
</article>
                      <article class="main-art river">
  <div class="row">
    <div class="col-sm-4 col-xs-5">
      <a href="https://appleinsider.com/articles/20/06/12/ten-years-of-apple-technology-shifts-made-the-arm-mac-possible"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/apps/ipad/images/articles/53207.jpg" alt="article thumbnail"></a>
      <img loading="lazy" class="avatar img-circle hidden-xs" src="https://photos5.appleinsider.com/gallery/amber+neely.jpg" alt="author image">
    </div>
    <div class="col-sm-8 col-xs-7">
      <div class="visible-xs">
        <p><a href="https://appleinsider.com/articles/20/06/12/warnermedia-retiring-hbo-go-rebranding-hbo-now-to-just-hbo">WarnerMedia retiring HBO Go, rebranding HBO Now to just HBO</a></p>
        <span class="avatar-link">18 hours ago </span>
      </div>
      <div class="row hidden-xs">
        <div class="col-sm-12">
          <h2 class="blueHover"><a href="https://appleinsider.com/articles/20/06/12/warnermedia-retiring-hbo-go-rebranding-hbo-now-to-just-hbo">WarnerMedia retiring HBO Go, rebranding HBO Now to just HBO</a></h2>
          In an attempt to consolidate services and alleviate confusion, WarnerMedia announces plans to retire HBO Go and rebrand HBO Now as simply &quot;HBO.&quot;
        </div>
        <!--
        <div class="col-sm-3">
          <span class="hidden-xs fauxH3">general</span>
        </div> -->
                <div class="col-sm-10 avatar-link river-author-byline">
          By <a href="https://appleinsider.com/editor/Amber+Neely">Amber Neely</a>  |  18 hours ago
        </div>
        <div class="col-sm-2 river-comments">
                    <a href="https://forums.appleinsider.com/discussion/216208"><span class="badge">5<span class="carrot"><img loading="lazy" src="https://photos5.appleinsider.com/v10/images/commentcarrot.png" alt="comment count carrot"></span></span></a>
                  </div>
      </div>
  </div>
  </div>
  <hr>
</article>
                  </div>
        <div class="col-lg-3">
          <div class="visible-xs">
            <hr class="visible-md">
<h2 class="uc">Related Articles</h2>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/12/arm-mac-transition-imac-redesign-and-our-wwdc-wishlist-on-the-appleinsider-podcast"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36179-67074-wwdc2020-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/12/arm-mac-transition-imac-redesign-and-our-wwdc-wishlist-on-the-appleinsider-podcast">ARM Mac transition, iMac redesign, and our WWDC wishlist on the AppleInsider podcast</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/08/what-to-expect-at-wwdc-2020----and-what-not-to"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36124-66928-000-lead-WWDC-2020-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/08/what-to-expect-at-wwdc-2020----and-what-not-to">What to expect at WWDC 2020 &amp;mdash; and what not to</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/11/apple-announces-wwdc-keynote-timeline-week-long-conference-schedule"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36175-67063-Apple_details-for-WWDC2020_06022020_bigjpglarge_2x-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/11/apple-announces-wwdc-keynote-timeline-week-long-conference-schedule">Apple announces WWDC keynote timeline, week-long conference schedule</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/11/how-to-manage-notifications-in-macos"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36153-67017-header-m.png" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/11/how-to-manage-notifications-in-macos">How to manage notifications in macOS</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/10/apple-was-cautious-when-it-shifted-to-intel-and-an-arm-mac-migration-will-be-no-different"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36139-67003-000-lead-Intel-move-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/10/apple-was-cautious-when-it-shifted-to-intel-and-an-arm-mac-migration-will-be-no-different">Apple was cautious when it shifted to Intel, and an ARM Mac migration will be no different</a></h2>
        </div>
    </div>
</article>
<hr>
          </div>
          <hr class="visible-md">
<h2 class="uc">
    Latest Videos
</h2>

    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/12/hands-on-adobe-photoshop-camera-ups-your-photo-game"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36180-67086-Photoshop-Camera-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/12/hands-on-adobe-photoshop-camera-ups-your-photo-game">Hands on: Adobe Photoshop Camera ups your photo game</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/09/review-zagg-rugged-book-go-slim-book-provide-protection-and-a-keyboard-for-ipad-pro"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36126-66968-Slim-Book-Go-and-Rugged-Book-Go-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/09/review-zagg-rugged-book-go-slim-book-provide-protection-and-a-keyboard-for-ipad-pro">Review: Zagg Rugged Book Go &amp; Slim Book provide protection and a keyboard for iPad Pro</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/05/review-steelseries-nimbus-is-the-ideal-apple-gaming-controller-for-iphone-ipad-mac-apple-tv"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36112-66879-Playing-Fortnite-on-SteelSeries-Nimbus+-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/05/review-steelseries-nimbus-is-the-ideal-apple-gaming-controller-for-iphone-ipad-mac-apple-tv">Review: SteelSeries Nimbus+ is the ideal Apple gaming controller for iPhone, iPad, Mac, &amp; Apple TV</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/04/review-hue-hdmi-sync-box-play-light-bar-creates-a-better-multimedia-experience"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36071-66794-Simpsons-Hue-Sync-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/04/review-hue-hdmi-sync-box-play-light-bar-creates-a-better-multimedia-experience">Review: Hue HDMI Sync box &amp; Play light bar creates a better multimedia experience</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/02/here-are-our-favorite-cases-for-iphone-se-2020"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/35979-66700-iPhoen-Se-2020-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/02/here-are-our-favorite-cases-for-iphone-se-2020">Here are our favorite cases for iPhone SE (2020)</a></h2>
        </div>
    </div>
</article>
<hr>
 <!-- Videos Sidebar -->
          <div class="boxes ad">
    <div class="box">
        <div id="div-gpt-ad-1588174358438-0" class="ad-mred" style='width: 300px; height: 250px; margin: 0 auto;'>
            <script>
                googletag.cmd.push(function() { googletag.display('div-gpt-ad-1588174358438-0'); });
            </script>
        </div>
    </div>
</div>
<hr class="visible-xs">
          <hr class="visible-md">
<h2 class="uc">
    Latest Reviews
</h2>

    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/06/review-ampere-side-pocket-lets-you-charge-your-phone-while-youre-on-the-move"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36031-66638-header-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/06/review-ampere-side-pocket-lets-you-charge-your-phone-while-youre-on-the-move">Review: Ampere Side Pocket lets you charge your phone while you&#039;re on the move</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/06/review-edge-desk-is-the-collapsable-work-from-home-desk-youre-looking-for"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/35924-66328-Edge-Desk-Outside-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/06/review-edge-desk-is-the-collapsable-work-from-home-desk-youre-looking-for">Review: Edge Desk is the collapsable, work-from-home desk you&#039;re looking for</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/06/05/apple-tv-review-dear-a-suprisingly-shallow-documentary-series"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/36078-66764-Dear_Photo_0109-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/06/05/apple-tv-review-dear-a-suprisingly-shallow-documentary-series">Apple TV+ review: &#039;Dear...&#039; a surprisingly shallow documentary series</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/05/29/review-central-park-an-animated-musical-triumph-for-apple-tv"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/35971-66472-Central_Park_Photo_010102-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/05/29/review-central-park-an-animated-musical-triumph-for-apple-tv">Review: &#039;Central Park&#039; an animated musical triumph for Apple TV+</a></h2>
        </div>
    </div>
</article>
<hr>
    <article class="main-art sidebar-article">
    <div class="row">
        <div class="col-sm-4 col-xs-5">
            <a href="https://appleinsider.com/articles/20/05/27/review-output-4k-hdr-and-charge-your-ipad-pro-with-moshis-new-usb-c-adapter"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/gallery/35916-66291-Moshi-USB-C-Adapter-m.jpg" alt="article thumbnail"></a>
        </div>
        <div class="col-sm-8 col-xs-7">
            <h2><a href="https://appleinsider.com/articles/20/05/27/review-output-4k-hdr-and-charge-your-ipad-pro-with-moshis-new-usb-c-adapter">Review: Output 4K HDR and charge your iPad Pro with Moshi&#039;s new USB-C adapter</a></h2>
        </div>
    </div>
</article>
<hr>
 <!-- Reviews Sidebar -->
        </div>
      </div>
      <div class="col-lg-9" id="news-river"></div>
      <div class="col-lg-9" id="river-load-more" data-current-page="1" data-href="/news/page/2">
    <div id="load-more">
        <a href="/news/page/2" id="load-more-link">
            <span>LOAD</span>
            <div class="ispinner ispinner--gray">
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
                <div class="ispinner__blade"></div>
            </div>
            <span>MORE</span>
        </a>
    </div>
</div>

  </div>
        <!-- FOOTER START --> 
         <div class="footer-cont">
            <div class="footer">
            <img loading="lazy" class="logo-footer center-block" src="https://photos5.appleinsider.com/v10/images/logoFooter.png" alt="Footer Logo">
            <div class="row">
               <div class="col-sm-4"></div>
               <div class="col-sm-4 center-block">
                  <div class="social-footer">
                     <a href="https://www.facebook.com/AppleInsiderdotcom"><div class="footer-social-image-FB"></div></a>
                     <a href="https://twitter.com/appleinsider"><div class="footer-social-image-T"></div></a>
                     <a href="https://www.instagram.com/appleinsider_official/"><div class="footer-social-image-E"></div></a>
                  </div>
               </div>
               <div class="col-sm-4"></div>
            </div>
            <div class="row">
               <div class="col-sm-12">
                  <ul class="nav footer-nav center-block text-center">
                    <li><a class="text-center" href="https://forums.appleinsider.com">Forums</a></li>
                    <li><a class="text-center" href="https://appleinsider.com/podcast">Podcast</a></li>
                    <li><a class="text-center" href="https://prices.appleinsider.com">Price Guides</a></li>
                    <li><a class="text-center" href="https://deals.appleinsider.com">Deals</a></li>
                    <li><a class="text-center" href="https://appleinsider.com/videos">Videos</a></li>
                    <li><a class="text-center" href="https://appleinsider.com/reviews">Reviews</a></li>
                    <li><a class="text-center" href="https://appleinsider.com/">News</a></li>
                  </ul>
               </div>
            </div>
            <hr>
            <div class="row">
               <div class="col-sm-5 copyright text-center">Copyright &copy; 2020, Quiller Media, Inc.</div>
               <div class="col-sm-2 center-block"> </div>
               <div class="col-sm-5 copyright text-center">
                <a href="https://appleinsider.com/contact">Contact Us</a> | 
                <a href="https://appleinsider.com/privacy">Privacy Policy</a> | 
                <a href="https://appleinsider.com/terms-of-use">Terms of Use</a> | 
                <a href="https://appleinsider.com/advertising">Advertise on AI</a>
               </div>
            </div>
         </div>
      </div>

        <!-- Google Analytics -->
        <script>
            !function(A,n,g,u,l,a,r){A.GoogleAnalyticsObject=l,A[l]=A[l]||function(){
            (A[l].q=A[l].q||[]).push(arguments)},A[l].l=+new Date,a=n.createElement(g),
            r=n.getElementsByTagName(g)[0],a.src=u,r.parentNode.insertBefore(a,r)
            }(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

            ga('create', 'UA-280331-5');
            ga('send', 'pageview');
        </script>
        
        <script src="https://photos5.appleinsider.com/v10/js/vendor.js?id=945caa881ea91c943909"></script>
        <script src="https://photos5.appleinsider.com/v10/js/app.js?id=ee2eecfab6389676ac63"></script>
          <script id="river-template" type="text/template">
<article class="main-art river">
  <div class="row">
    <div class="col-sm-4 col-xs-5">
      <a href="{{ link }}"><img loading="lazy" class="img-responsive" src="https://photos5.appleinsider.com/apps/ipad/images/articles/{{id}}.jpg" alt="article thumbnail"></a>
      <img loading="lazy" class="avatar img-circle hidden-xs" src="{{ authorImage }}" alt="author profile image">
    </div>
    <div class="col-sm-8 col-xs-7">
      <div class="visible-xs">
        <p><a href="{{ link }}">{{ title }}</a></p>
        <span class="avatar-link">{{ dateFormatted }} </span>
      </div>
      <div class="row hidden-xs">
        <div class="col-sm-12">
          <h2 class="blueHover"><a href="{{ link }}">{{ title }}</a></h2>
          {{ summary }}
        </div>
        {{{ starsTemplateString }}}
        <div class="col-sm-10 avatar-link river-author-byline">
          By <a href="{{ authorLink }}">{{ author }}</a>  |  {{ dateFormatted }} 
        </div>
        <div class="col-sm-2 river-comments">
          <a href="{{ commentsLink }}"><span class="badge">{{ commentCount }}<span class="carrot"><img loading="lazy" src="https://photos5.appleinsider.com/v10/images/commentcarrot.png" alt="comment count carrot"></span></span></a>
        </div>        
      </div>
    </div>
  </div>
  <hr>
</article>
</script>
  <script id="river-ad-template" type="text/template">
    <div class="ad-mrec river-ad" style="width: 300px; height: 250px; margin: 0 auto; overflow: hidden; margin-bottom: 10px;">
    </div>
    <script>
        let n = Math.round(new Date().getTime());
        let element = $('.river-ad:last');
        let divName = "ad-river-"+n;
        element.append('<div id="'+divName+'"></div>');
        googletag.defineSlot('/53013535/Load_More_News_River_Pop_300x250', [300, 250], divName).addService(googletag.pubads());
        googletag.cmd.push(function() { googletag.display(divName); });
    </script>
</script>
  <script src="https://photos5.appleinsider.com/v10/js/article.js?id=e21ce889ec13096a8104"></script>
    </body>
</html>
